ayit第十六周训练题a题

You, as a member of a development team for a new spell checking program, are to write a module that will check the correctness of given words using a known dictionary of all correct words in all their forms.
If the word is absent in the dictionary then it can be replaced by correct words (from the dictionary) that can be obtained by one of the following operations:
?deleting of one letter from the word;
?replacing of one letter in the word with an arbitrary letter;
?inserting of one arbitrary letter into the word.
Your task is to write the program that will find all possible replacements from the dictionary for every given word.

Input

The first part of the input file contains all words from the dictionary. Each word occupies its own line. This part is finished by the single character '#' on a separate line. All words are different. There will be at most 10000 words in the dictionary.
The next part of the file contains all words that are to be checked. Each word occupies its own line. This part is also finished by the single character '#' on a separate line. There will be at most 50 words that are to be checked.
All words in the input file (words from the dictionary and words to be checked) consist only of small alphabetic characters and each one contains 15 characters at most.

Output

Write to the output file exactly one line for every checked word in the order of their appearance in the second part of the input file. If the word is correct (i.e. it exists in the dictionary) write the message: " is correct". If the word is not correct then write this word first, then write the character ':' (colon), and after a single space write all its possible replacements, separated by spaces. The replacements should be written in the order of their appearance in the dictionary (in the first part of the input file). If there are no replacements for this word then the line feed should immediately follow the colon.

Sample Input

i
is
has
have
be
my
more
contest
me
too
if
award
#
me
aware
m
contest
hav
oo
or
i
fi
mre
#

Sample Output

me is correct
aware: award
m: i my me
contest is correct
hav: has have
oo: too
or:
i is correct
fi: i
mre: more me
#include<stdio.h>
#include<string.h>
#include<math.h>
struct node
{
    char s[30];
    int t;
} f1[10010];
int a1(char a[110],char b[150])
{
    int i,t=0,l1,l2;
    l1=strlen(a);
    l2=strlen(b);
    if(l1<l2)
    {
        for(i=0; i<l2; i++)
        {
            if(a[t]==b[i])
                t++;
            if(t==l1)
                return 1;
        }
        return 0;
    }
    else if(l1>l2)
    {
        for(i=0; i<l1; i++)
        {
            if(a[i]==b[t])
                t++;
            if(t==l2)
                return 1;
        }
        return 0;
    }
    else
    {
        for(i=0; i<l1; i++)
        {
            if(a[i]==b[i])
                t++;
        }
        if(t==l1-1)
            return 1;
        else
            return 0;
    }
}
int main()
{
    int n=0,f=0,i;
    char c[20];
    while(~scanf("%s",c)&&c[0]!='#')
    {
        strcpy(f1[n].s,c);
        f1[n++].t=n;
    }
    while(~scanf("%s",c)&&c[0]!='#')
    {
        f=0;
        for(i=0; i<n; i++)
        {
            if(strcmp(c,f1[i].s)==0)
            {
                printf("%s is correct",c);
                f=1;
                break;
            }
        }
        if(!f)
        {
            printf("%s:",c);
            int l=strlen(c);
            for(i=0; i<n; i++)
            {
                if(strlen(f1[i].s)-l==1||strlen(f1[i].s)-l==-1||strlen(f1[i].s)-l==0)
                {
                    if(a1(c,f1[i].s))
                        printf(" %s");
                }
            }
        }
        printf("\n");
    }
    return 0;
}
题意   第一个#号前是给出的现有的词汇,第二个#号前是需要查找的单词:1.改动一个字母。2.去掉一个字母。3.增加一个字母。满足任一条件能在词库中找出就输出。

思路   能直接找到与需要变换,需要变换分直接字母变化与增减。相同长度情况需要判断是否为原单词与需改变一个字母的情况,不同长度可以理解为长的枚举去掉一个字母后与短的进行匹配。使用按顺序统计匹配字母个数,再与短字符串长度比较判断。

猜你喜欢

转载自blog.csdn.net/m0_46628834/article/details/106607898
今日推荐