ayit第十三周周赛 a题

某省调查乡村交通状况,得到的统计表中列出了任意两村庄间的距离。省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可),并要求铺设的公路总长度为最小。请计算最小的公路总长度。

Input

测试输入包含若干测试用例。每个测试用例的第1行给出村庄数目N ( < 100 );随后的N(N-1)/2行对应村庄间的距离,每行给出一对正整数,分别是两个村庄的编号,以及此两村庄间的距离。为简单起见,村庄从1到N编号。
当N为0时,输入结束,该用例不被处理。

Output

对每个测试用例,在1行里输出最小的公路总长度。

Sample Input

3
1 2 1
1 3 2
2 3 4
4
1 2 1
1 3 4
1 4 1
2 3 3
2 4 2
3 4 5
0

Sample Output

3
5


        
  
Huge input, scanf is recommended.

Hint

Hint
        
 
#include<stdio.h>
#include<algorithm>
using namespace std;
int f[110];
struct node
{
    int x,y,z;
} a[5010];
bool cmp(node a,node b)
{
    return a.z<b.z;
}
int find(int x)
{
    return f[x]==x?x:find(f[x]);
}
int main()
{
    int N,n,i,b,c;
    while(~scanf("%d",&N)&&N!=0)
    {
        int s=0;
        n=N*(N-1)/2;
        for(i=1; i<=N; i++)
            f[i]=i;
        for(i=1; i<=n; i++)
            scanf("%d%d%d",&a[i].x,&a[i].y,&a[i].z);
        sort(a+1,a+1+n,cmp);
        for(i=1; i<=n; i++)
        {
            int b=find(a[i].x);
            int c=find(a[i].y);
            if(b==c)
            continue;
            f[c]=b;
            s+=a[i].z;
        }
        printf("%d\n",s);
    }
    return 0;
}

题意   求出题中所给起点到终点的最短距离

思路 先把图中的所有边按权值从小到大排序,再所选的边连接的两个顶点a,b,应属于两颗不同的树,则成为最小生成树的一条         边,并将这两颗树合并作为一颗树,直到所有顶点都在一颗树内或者树上有n-1条边为止。

猜你喜欢

转载自blog.csdn.net/m0_46628834/article/details/106178774