[The Preliminary Contest for ICPC Asia Xuzhou 2019 - 徐州网络赛C] Buy Watermelon

Buy Watermelon

The hot summer came so quickly that Xiaoming and Xiaohong decided to buy a big and sweet watermelon. But they are two very strange people. They are even-numbered enthusiasts. They want to cut the watermelon in two parts, and each part weighs two times as much as a kilogram .They quickly decide which melon to buy. Do you know if you want to buy this melon?

Input

Only one line contains one integer ww (1\leq w\leq 100)(1≤w≤100),units are kilograms.

Output

If it can meet the requirements, you will output YES, otherwise output NO.

样例输入

8

样例输出

YES

原本以为是对半分,使得分成的两半都为 2 的倍数。然而实际上是,任意分成两份,只要有一种情况满足条件即可。

#include <bits/stdc++.h>
#define ll long long
#define INF 0x3f3f3f3f
using namespace std;
int w;

void read()
{
    cin >> w;
}

void solve()
{
    if((w&1) | (w==2))
        cout << "NO" << endl;
    else
        cout << "YES" << endl;
}

int main()
{
    ios::sync_with_stdio(false);
    cin.tie(0); cout.tie(0);
    read();
    solve();
    return 0;
}

猜你喜欢

转载自blog.csdn.net/HNUCSEE_LJK/article/details/100637984