HDU 1800 Flying to the Mars (贪心)

题面

In the year 8888, the Earth is ruled by the PPF Empire . As the population growing , PPF needs to find more land for the newborns . Finally , PPF decides to attack Kscinow who ruling the Mars . Here the problem comes! How can the soldiers reach the Mars ? PPF convokes his soldiers and asks for their suggestions . “Rush … ” one soldier answers. “Shut up ! Do I have to remind you that there isn’t any road to the Mars from here!” PPF replies. “Fly !” another answers. PPF smiles :“Clever guy ! Although we haven’t got wings , I can buy some magic broomsticks from HARRY POTTER to help you .” Now , it’s time to learn to fly on a broomstick ! we assume that one soldier has one level number indicating his degree. The soldier who has a higher level could teach the lower , that is to say the former’s level > the latter’s . But the lower can’t teach the higher. One soldier can have only one teacher at most , certainly , having no teacher is also legal. Similarly one soldier can have only one student at most while having no student is also possible. Teacher can teach his student on the same broomstick .Certainly , all the soldier must have practiced on the broomstick before they fly to the Mars! Magic broomstick is expensive !So , can you help PPF to calculate the minimum number of the broomstick needed .
For example :
There are 5 soldiers (A B C D E)with level numbers : 2 4 5 6 4;
One method :
C could teach B; B could teach A; So , A B C are eligible to study on the same broomstick.
D could teach E;So D E are eligible to study on the same broomstick;
Using this method , we need 2 broomsticks.
Another method:
D could teach A; So A D are eligible to study on the same broomstick.
C could teach B; So B C are eligible to study on the same broomstick.
E with no teacher or student are eligible to study on one broomstick.
Using the method ,we need 3 broomsticks.
……

After checking up all possible method, we found that 2 is the minimum number of broomsticks needed.

Input
Input file contains multiple test cases.
In a test case,the first line contains a single positive number N indicating the number of soldiers.(0<=N<=3000)
Next N lines :There is only one nonnegative integer on each line , indicating the level number for each soldier.( less than 30 digits);

Output
For each case, output the minimum number of broomsticks on a single line.

Sample Input
4
10
20
30
04
5
2
3
4
3
4

Sample Output
1
2

思路

水题,简单贪心,排个序,然后从最长的开始往下遍历并累加所需扫帚就可以了,有两个细节点,读入的话,因为这个数据太社会了,我们得搞点奇技淫巧,快读走起来,然后还有一个不开long long 见祖宗。

代码实现

#include<cstdio>
#include<algorithm>
#include<iostream>
#include<cmath>
#include<cstring>
using namespace std;
typedef long long ll;
const int maxn=3005;
int vis[maxn];
ll a[maxn];
inline ll read() {
    char ch = getchar(); ll x = 0, f = 1;
    while(ch < '0' || ch > '9') {
        if(ch == '-') f = -1;
        ch = getchar();
    } while('0' <= ch && ch <= '9') {
        x = x * 10 + ch - '0';
        ch = getchar();
    } return x * f;
}
bool camp (ll x,ll y) {
    return x>y;
}
int main () {
   int n;
   int cnt=0;
   ll temp=0;
   while (cin>>n) {
      ll cnt=0;
      temp=0;
      memset (vis,0,sizeof (vis));
      for (int i=1;i<=n;i++) a[i]=read();
      sort(a+1,a+1+n,camp);
      for (int i=1;i<=n;i++) {
          if (!vis[i]) {
              temp=a[i];
              vis[i]=1;
              cnt++;
              for (int j=i+1;j<=n;j++) {
                  
                  if (!vis[j]&&a[j]<temp) vis[j]=1,temp=a[j];
              }
          }
      }
      cout<<cnt<<endl;
   }
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/hhlya/p/13164189.html