XYNUOJ 魔法扫帚/Hdu 1800 Flying to the Mars(简易算法非贪心)

                                     Flying to the Mars

               Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Problem Description


In the year 8888, the Earth is ruled by the PPF Empire . As the population growing , PPF needs to find more land for the newborns . Finally , PPF decides to attack Kscinow who ruling the Mars . Here the problem comes! How can the soldiers reach the Mars ? PPF convokes his soldiers and asks for their suggestions . “Rush … ” one soldier answers. “Shut up ! Do I have to remind you that there isn’t any road to the Mars from here!” PPF replies. “Fly !” another answers. PPF smiles :“Clever guy ! Although we haven’t got wings , I can buy some magic broomsticks from HARRY POTTER to help you .” Now , it’s time to learn to fly on a broomstick ! we assume that one soldier has one level number indicating his degree. The soldier who has a higher level could teach the lower , that is to say the former’s level > the latter’s . But the lower can’t teach the higher. One soldier can have only one teacher at most , certainly , having no teacher is also legal. Similarly one soldier can have only one student at most while having no student is also possible. Teacher can teach his student on the same broomstick .Certainly , all the soldier must have practiced on the broomstick before they fly to the Mars! Magic broomstick is expensive !So , can you help PPF to calculate the minimum number of the broomstick needed .
For example : 
There are 5 soldiers (A B C D E)with level numbers : 2 4 5 6 4;
One method :
C could teach B; B could teach A; So , A B C are eligible to study on the same broomstick.
D could teach E;So D E are eligible to study on the same broomstick;
Using this method , we need 2 broomsticks.
Another method:
D could teach A; So A D are eligible to study on the same broomstick.
C could teach B; So B C are eligible to study on the same broomstick.
E with no teacher or student are eligible to study on one broomstick.
Using the method ,we need 3 broomsticks.
……

After checking up all possible method, we found that 2 is the minimum number of broomsticks needed. 

Input

Input file contains multiple test cases. 
In a test case,the first line contains a single positive number N indicating the number of soldiers.(0<=N<=3000)
Next N lines :There is only one nonnegative integer on each line , indicating the level number for each soldier.( less than 30 digits);

Output

For each case, output the minimum number of broomsticks on a single line.

Sample Input

4 10 20 30 04 5 2 3 4 3 4

Sample Output

1 2

该题思想:

每人都有对应级别,同级的无法互相传授。所有的匹配都成链性关系,那么形成的链数+超出部分即为所求扫帚数 即 在相应级别上有最多的魔法师数量即为所求值。

所以我们可以先建立数组存储输入的数据并sort排序,再利用比较各个级别的人数t,循环判断找出最大值max,最后将它输出

AC代码:

#include <iostream>					 //B - Flying to the Mars
#include<cstring>
#include <algorithm>
using namespace std;

int main(){
    int n;
    while(~scanf("%d",&n)){
       	int a[3001],i,level,max=1;
       	memset(a,0,sizeof(a));
        for(i=0;i<n;i++) scanf("%d",&a[i]);
        sort(a,a+n);         //降序排序 
        int t=1;             //计数各个级别的人数 
        for(i=0;i<n-1;i++){  //循环找出最大值 
            if(a[i]==a[i+1]) t++; //若级别相同t++ 
            else t=1;             //否则重置t 
            if(max<t) max=t;      //判断t是否>max 
        }
        printf("%d\n",max);  //输出最大值 
    }
    return 0;
}

 第一次出错代码:

        for(i=0;i<n;i++){       //不太理解下面代码为什么会出错,换个形式就对了
            scanf("%d",&level); //以后尽可能不用数组+scanf所输入的值进行判断 
            a[level]++;         //计数 输入的等级 
            if(a[level]>max) max=a[level];  //寻找最大值                     
        }

猜你喜欢

转载自blog.csdn.net/qq_30007603/article/details/81292255