【HDU 1800】Flying to the Mars(STL map)

Flying to the Mars


Description
In the year 8888, the Earth is ruled by the PPF Empire . As the population growing , PPF needs to find more land for the newborns . Finally , PPF decides to attack Kscinow who ruling the Mars . Here the problem comes! How can the soldiers reach the Mars ? PPF convokes his soldiers and asks for their suggestions . “Rush … ” one soldier answers. “Shut up ! Do I have to remind you that there isn’t any road to the Mars from here!” PPF replies. “Fly !” another answers. PPF smiles :“Clever guy ! Although we haven’t got wings , I can buy some magic broomsticks from HARRY POTTER to help you .” Now , it’s time to learn to fly on a broomstick ! we assume that one soldier has one level number indicating his degree. The soldier who has a higher level could teach the lower , that is to say the former’s level > the latter’s . But the lower can’t teach the higher. One soldier can have only one teacher at most , certainly , having no teacher is also legal. Similarly one soldier can have only one student at most while having no student is also possible. Teacher can teach his student on the same broomstick .Certainly , all the soldier must have practiced on the broomstick before they fly to the Mars! Magic broomstick is expensive !So , can you help PPF to calculate the minimum number of the broomstick needed .
For example :
There are 5 soldiers (A B C D E)with level numbers : 2 4 5 6 4;
One method :
C could teach B; B could teach A; So , A B C are eligible to study on the same broomstick.
D could teach E;So D E are eligible to study on the same broomstick;
Using this method , we need 2 broomsticks.
Another method:
D could teach A; So A D are eligible to study on the same broomstick.
C could teach B; So B C are eligible to study on the same broomstick.
E with no teacher or student are eligible to study on one broomstick.
Using the method ,we need 3 broomsticks.
……

After checking up all possible method, we found that 2 is the minimum number of broomsticks needed.

Input
Input file contains multiple test cases.
In a test case,the first line contains a single positive number N indicating the number of soldiers.(0<=N<=3000)
Next N lines :There is only one nonnegative integer on each line , indicating the level number for each soldier.( less than 30 digits);

Output
For each case, output the minimum number of broomsticks on a single line.


Sample Input
4
10
20
30
04
5
2
3
4
3
4

Sample Output
1
2


题意:

大佬带菜鸟学用扫帚飞行。等级高的可以和等级低的同坐一个扫帚。问最少需要几个扫帚。


思路:

既然等级高的可以和等级低的坐一个,那么只需求出同一等级的最大人数即可。如 1 5 4 3 4 2 2这样一组数据,5 4 3 2 1可以坐同一把扫帚,而4 2只能另坐一把扫帚。因此需要2把扫帚。也即等级为4或2的人数有2人,需要2把扫帚。
第一次用到map(map详解),记录一下。

  • map< int,int > mp;申明mp为一个 map容器
    mp::iterator it;申明it是一个迭代器
    it->second;返回map中的值
    p.begin()为容器起始端,p.end()为容器终端

此题的map用来记录人数,每个等级的人数。最后找出最大的人数即可。


代码:

#include<iostream>
#include<map>
using namespace std;

typedef map<int,int> mp;
mp p;
mp::iterator it;
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        p.clear();
        int i,temp;
        for(int i=0;i<n;i++) {
            scanf("%d",&temp);
            p[temp]++;
        }
        int nmax=0;
        for(it=p.begin();it!=p.end();it++)
            if(it->second>nmax) nmax=it->second;

        printf("%d\n",nmax);
    }

    return 0;
 } 

猜你喜欢

转载自blog.csdn.net/chen_yuazzy/article/details/77527330