LOOPS HDU - 3853(概率dp,期望)

题意:

有一个R*C的方格。一个人想从(1,1)走到(r,c)。在每个格子都有三种选择,向下,向右,或者原地不动。每个格子里的每个选择都有一定的概率。而每次移动都需要消耗2点的能量,问期望消耗的能量是多少。

题目:

Akemi Homura is a Mahou Shoujo (Puella Magi/Magical Girl).

Homura wants to help her friend Madoka save the world. But because of the plot of the Boss Incubator, she is trapped in a labyrinth called LOOPS.
在这里插入图片描述

The planform of the LOOPS is a rectangle of R*C grids. There is a portal in each grid except the exit grid. It costs Homura 2 magic power to use a portal once. The portal in a grid G(r, c) will send Homura to the grid below G (grid(r+1, c)), the grid on the right of G (grid(r, c+1)), or even G itself at respective probability (How evil the Boss Incubator is)!
At the beginning Homura is in the top left corner of the LOOPS ((1, 1)), and the exit of the labyrinth is in the bottom right corner ((R, C)). Given the probability of transmissions of each portal, your task is help poor Homura calculate the EXPECT magic power she need to escape from the LOOPS.

Input

The first line contains two integers R and C (2 <= R, C <= 1000).

The following R lines, each contains C*3 real numbers, at 2 decimal places. Every three numbers make a group. The first, second and third number of the cth group of line r represent the probability of transportation to grid (r, c), grid (r, c+1), grid (r+1, c) of the portal in grid (r, c) respectively. Two groups of numbers are separated by 4 spaces.

It is ensured that the sum of three numbers in each group is 1, and the second numbers of the rightmost groups are 0 (as there are no grids on the right of them) while the third numbers of the downmost groups are 0 (as there are no grids below them).

You may ignore the last three numbers of the input data. They are printed just for looking neat.

The answer is ensured no greater than 1000000.

Terminal at EOF

Output

A real number at 3 decimal places (round to), representing the expect magic power Homura need to escape from the LOOPS.

Sample Input

2 2
0.00 0.50 0.50 0.50 0.00 0.50
0.50 0.50 0.00 1.00 0.00 0.00

Sample Output

6.000

分析:

f[i][j]为从(i,j)到(r,c)的期望消耗。G[i][j][k]记录每次走动三种选择的概率从(i,j)有三种转移方法向下。
在原地不动的概率是G[i][j][1];
向右的概率为G[i][j][2];
向下的概率为G[i][j][3]。
但是在原地不动是不消耗能量的.所以转移我们只考虑转移到右边和下边的情况。
f[i][j]=f[i][j]*G[i][j][1]+f[i+1][j]*G[i][j][2]+f[i][j+1]*G[i][j][3]+2
将f[i][j]*G[i][j][1]移到左边,得到状态转移方程
f[i][j]=(f[i+1][j]*G[i][j][2]+f[i][j+1]*G[i][j][3]+2)/(1-G[i][j][1]).

AC代码

#include <cstdio>
#include <algorithm>
#include <cstring>
#include <iostream>
#include <cmath>
using namespace std;
const int M=1e3+10;
const int eps=1e-5;
double G[M][M][5];
double f[M][M];
int r,c;
int main()
{
    while(~scanf("%d%d",&r,&c)&&r&&c)
    {
        for(int i=1; i<=r; i++)
            for(int j=1; j<=c; j++)
                for(int l=1; l<=3; l++)
                    scanf("%lf",&G[i][j][l]);
        memset(f,0,sizeof(f));
        for(int i=r; i>=1; i--)
            for(int j=c; j>=1; j--)
            {
                if(i==r&&j==c)
                    continue;
                if(fabs(1-G[i][j][1])<=eps)
                    continue;
                f[i][j]=(f[i][j+1]*G[i][j][2]+f[i+1][j]*G[i][j][3]+2)/(1-G[i][j][1]);
            }
        printf("%.3f\n",f[1][1]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/zeng_jun_yv/article/details/105128136
今日推荐