hdu3853_LOOPS

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/sumword_/article/details/53162140

LOOPS


Problem Description
Akemi Homura is a Mahou Shoujo (Puella Magi/Magical Girl).

Homura wants to help her friend Madoka save the world. But because of the plot of the Boss Incubator, she is trapped in a labyrinth called LOOPS.

The planform of the LOOPS is a rectangle of R*C grids. There is a portal in each grid except the exit grid. It costs Homura 2 magic power to use a portal once. The portal in a grid G(r, c) will send Homura to the grid below G (grid(r+1, c)), the grid on the right of G (grid(r, c+1)), or even G itself at respective probability (How evil the Boss Incubator is)!
At the beginning Homura is in the top left corner of the LOOPS ((1, 1)), and the exit of the labyrinth is in the bottom right corner ((R, C)). Given the probability of transmissions of each portal, your task is help poor Homura calculate the EXPECT magic power she need to escape from the LOOPS.




 

Input
The first line contains two integers R and C (2 <= R, C <= 1000).

The following R lines, each contains C*3 real numbers, at 2 decimal places. Every three numbers make a group. The first, second and third number of the cth group of line r represent the probability of transportation to grid (r, c), grid (r, c+1), grid (r+1, c) of the portal in grid (r, c) respectively. Two groups of numbers are separated by 4 spaces.

It is ensured that the sum of three numbers in each group is 1, and the second numbers of the rightmost groups are 0 (as there are no grids on the right of them) while the third numbers of the downmost groups are 0 (as there are no grids below them).

You may ignore the last three numbers of the input data. They are printed just for looking neat.

The answer is ensured no greater than 1000000.

Terminal at EOF


 

Output
A real number at 3 decimal places (round to), representing the expect magic power Homura need to escape from the LOOPS.

 

Sample Input
 
  
2 2 0.00 0.50 0.50 0.50 0.00 0.50 0.50 0.50 0.00 1.00 0.00 0.00
 

Sample Output
 
  
6.000

题意:一个人,从坐上角走到右下角,每个格子,静止不动,向右,向下走的概率分别为p1,p2,p3每走一次花费两个魔力,问走完花费的魔力的期望。
思路:DP[i][j] 表示从(i, j)到(n,m)所需要的魔力值,这时候就可以得出转移方程dp[i][j] = p[i][j][1]*dp[i][j] + p[i][j][2]*dp[i][j+1] + p[i][j][3]*dp[i+1][j] + 2  注意这时的dp[i][j]相当于一个未知量x,然后解方程,得出dp[i][j] = (p[i][j][2]*dp[i][j+1] + p[i][j][3]*dp[i+1][j] + 2)/(1-p[i][j][1]),注意当p1 == 1时,dp[i][j]应该等于零。这是因为,如果这个点不可能走到,说明经过这个点的所有的线路对最终结果的贡献是0。
#include<bits/stdc++.h>
using namespace std;
struct K{
    double re;
    double right;
    double down;
}node[1005][1005];
double dp[1005][1005];
int main(){

    int n,m;
    while(scanf("%d%d",&n,&m) == 2){
        for(int i = 1; i <= n; i++)
            for(int j = 1; j <= m; j++)
                scanf("%lf%lf%lf",&node[i][j].re,&node[i][j].right,&node[i][j].down);
        dp[n][m] = 0;
        for(int i = n; i >= 1; i--)
            for(int j = m; j >= 1; j--){
                if(i == n && j == m || node[i][j].re == 1){
                    dp[i][j] = 0;
                    continue;
                }
                dp[i][j] = (dp[i+1][j]*node[i][j].down + dp[i][j+1]*node[i][j].right + 2) / (1.0-node[i][j].re);
            }
        printf("%.3lf\n",dp[1][1]);

    }
}


猜你喜欢

转载自blog.csdn.net/sumword_/article/details/53162140