LOOPS (概率dp)

Akemi Homura is a Mahou Shoujo (Puella Magi/Magical Girl). 

Homura wants to help her friend Madoka save the world. But because of the plot of the Boss Incubator, she is trapped in a labyrinth called LOOPS. 


The planform of the LOOPS is a rectangle of R*C grids. There is a portal in each grid except the exit grid. It costs Homura 2 magic power to use a portal once. The portal in a grid G(r, c) will send Homura to the grid below G (grid(r+1, c)), the grid on the right of G (grid(r, c+1)), or even G itself at respective probability (How evil the Boss Incubator is)! 
At the beginning Homura is in the top left corner of the LOOPS ((1, 1)), and the exit of the labyrinth is in the bottom right corner ((R, C)). Given the probability of transmissions of each portal, your task is help poor Homura calculate the EXPECT magic power she need to escape from the LOOPS. 


 

Input

The first line contains two integers R and C (2 <= R, C <= 1000). 

The following R lines, each contains C*3 real numbers, at 2 decimal places. Every three numbers make a group. The first, second and third number of the cth group of line r represent the probability of transportation to grid (r, c), grid (r, c+1), grid (r+1, c) of the portal in grid (r, c) respectively. Two groups of numbers are separated by 4 spaces. 

It is ensured that the sum of three numbers in each group is 1, and the second numbers of the rightmost groups are 0 (as there are no grids on the right of them) while the third numbers of the downmost groups are 0 (as there are no grids below them). 

You may ignore the last three numbers of the input data. They are printed just for looking neat. 

The answer is ensured no greater than 1000000. 

Terminal at EOF 

 

Output

A real number at 3 decimal places (round to), representing the expect magic power Homura need to escape from the LOOPS. 
 

Sample Input

2 2
0.00 0.50 0.50    0.50 0.00 0.50
0.50 0.50 0.00    1.00 0.00 0.00

Sample Output

6.000
有一个r*c的格子,从格子(1,1)出发,可以保持三种姿势,留在原地,向右一步,向下一步,且给出相应的概率,每走一步消耗2的魔法值,问最后到达(r,c)平均需要多少魔法值、
设dp[i][j]表示(i,j)到(R,C)需要消耗的能量

dp[i][j]=dp[i][j+1]*p[i][j][1]+dp[i+1][j]*p[i][j][2]+2;

 dp[i][j]/=(1.0-p[i][j][0]); 

#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;
const double eps=1e-8;
double p[1005][1005][3];
double dp[1005][1005];
bool equal(double a,double b){
	return fabs(a-b)<eps;
}
int main(){
	int r,c;
	while(~scanf("%d%d",&r,&c)){
		for(int i=1;i<=r;i++){
			for(int j=1;j<=c;j++){
				scanf("%lf%lf%lf",&p[i][j][0],&p[i][j][1],&p[i][j][2]);
			}
		}
		memset(dp,0,sizeof(dp));
		for(int i=r;i>0;i--){
			for(int j=c;j>0;j--){
				if(i==r&&j==c)
				continue;
				if(!equal(p[i][j][0],1.0)){
					dp[i][j]=dp[i][j+1]*p[i][j][1]+dp[i+1][j]*p[i][j][2]+2;
					dp[i][j]/=(1.0-p[i][j][0]); 
				}
			}
		}
		printf("%.3f\n",dp[1][1]);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_42936517/article/details/87932073