LightOJ - 1079 概率

As Harry Potter series is over, Harry has no job. Since he wants to make quick money, (he wants everything quick!) so he decided to rob banks. He wants to make a calculated risk, and grab as much money as possible. But his friends - Hermione and Ron have decided upon a tolerable probability P of getting caught. They feel that he is safe enough if the banks he robs together give a probability less than P.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case contains a real number P, the probability Harry needs to be below, and an integer N (0 < N ≤ 100), the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj (0 < Mj ≤ 100) and a real number Pj . Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj. A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.

Output

For each case, print the case number and the maximum number of millions he can expect to get while the probability of getting caught is less than P.

Sample Input

3

0.04 3

1 0.02

2 0.03

3 0.05

0.06 3

2 0.03

2 0.03

3 0.05

0.10 3

1 0.03

2 0.02

3 0.05

Sample Output

Case 1: 2

Case 2: 4

Case 3: 6

Note

For the first case, if he wants to rob bank 1 and 2, then the probability of getting caught is 0.02 + (1 - 0.02) * .03 = 0.0494 which is greater than the given probability (0.04). That's why he has only option, just to rob rank 2.

概率做01背包 

一个人抢钱,每个物品有一个危险概率(double),一个价值,问低于p危险概率下,获得的最大收益

dp[i]表示抢到i元时不被抓到的最大概率
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm> 
using namespace std;


const int maxn = 1e2+5;
double dp[100005];

struct node{
	int value;
	double p;
}a[maxn];

int main()
{
	int t;
	cin >> t;
	for(int k = 1; k <= t; k++)
	{
		double va;
		int n ;
		cin >> va >> n; 
		int sum = 0;
		for(int i = 0; i < n; i++)
		{
			cin >> a[i].value >> a[i].p;
			a[i].p = 1 - a[i].p;
			sum += a[i].value;
		}
		memset(dp, 0, sizeof dp);
		dp[0] = 1;
		for(int i = 0; i < n; i++)
			for(int j = sum; j >= a[i].value; j--)
				dp[j] = max(dp[j], dp[j-a[i].value]*a[i].p);
		int i;
		for(i = sum; i >= 0; i--)  
        {  
            if(1-dp[i] <= va)  
                break;  
        }
       printf("Case %d: %d\n", k, i);
	}
	return 0;	
 } 

猜你喜欢

转载自blog.csdn.net/qq_38295645/article/details/80468536