LightOJ 1079 Just another Robbery【概率DP】

版权声明:转载什么的好说,附上友链就ojek了,同为咸鱼,一起学习。<br> https://blog.csdn.net/sodacoco/article/details/89025403

题目:

As Harry Potter series is over, Harry has no job. Since he wants to make quick money, (he wants everything quick!) so he decided to rob banks. He wants to make a calculated risk, and grab as much money as possible. But his friends - Hermione and Ron have decided upon a tolerable probability P of getting caught. They feel that he is safe enough if the banks he robs together give a probability less than P.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case contains a real number P, the probability Harry needs to be below, and an integer N (0 < N ≤ 100), the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj (0 < Mj ≤ 100) and a real number Pj . Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj. A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.

Output

For each case, print the case number and the maximum number of millions he can expect to get while the probability of getting caught is less than P.

Sample Input

3

0.04 3

1 0.02

2 0.03

扫描二维码关注公众号,回复: 5785174 查看本文章

3 0.05

0.06 3

2 0.03

2 0.03

3 0.05

0.10 3

1 0.03

2 0.02

3 0.05

Sample Output

Case 1: 2

Case 2: 4

Case 3: 6

Note

For the first case, if he wants to rob bank 1 and 2, then the probability of getting caught is 0.02 + (1 - 0.02) * .03 = 0.0494 which is greater than the given probability (0.04). That's why he has only option, just to rob rank 2.

题目大意: 

       n 个银行,抢第 i 个银行,有 pi 被抓的风险,将抢到 mi 的钱数,现给定一个最大风险P,求在该风险范围内求能抢到的最大钱数。

z解题思路:

       有三个变量,抢的银行数目,抢到的钱数,被抓到的概率,于是采用二维数组表示:dp[ i ][ j ]表示 在前 i 家银行抢劫 j 元的最小概率。

        则将初始值设为 1 , 以便求出最小概率【概率最大值为1,最小值为0】;

       状态转移方程: dp[ i ][ j ]=min(dp[ i-1 ][ j ],dp[ i-1 ][ j-m[ i ] ]+( 1 - dp[ i-1 ][ j-m[ i ] ] )*p[ i ] )

实现代码:

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<algorithm>
using namespace std;

int n,m[105];
double k,p[110],dp[110][10010];
int main(){
    int T,t;
    scanf("%d",&T);
    for(t=1;t<=T;t++){
        scanf("%lf %d",&k,&n);  //最大被抓概率

        int sum=0;
        for(int i=1;i<=n;i++){
            scanf("%d %lf",&m[i],&p[i]);
            sum+=m[i];
        }
        for(int j=1;j<=sum;j++) //求最小概率,初值设为
            dp[0][j]=1;

        for(int i=1;i<=n;i++){
            for(int j=1;j<=sum;j++){
                if(j>=m[i])     //抢到的钱随着抢劫银行的数量增加或者不变
                    dp[i][j]=min(dp[i-1][j],dp[i-1][j-m[i]]+(double)(1-dp[i-1][j-m[i]])*p[i]);//当j > m[i]的时候存在两种可能:抢劫该银行,不抢劫该银行。这时选择最小值。
                else            //不抢,延续上一家的概率
                    dp[i][j]=dp[i-1][j];
            }
        }
        int ans=0;
        for(int j=1;j<=sum;j++){
            if(dp[n][j]<k)      //找 靠后的,满足概率需求的 最大钱数
                ans=j;
        }
        printf("Case %d: %d\n",t,ans);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/sodacoco/article/details/89025403
今日推荐