LightOJ 1104 Birthday Paradox【概率】

版权声明:转载什么的好说,附上友链就ojek了,同为咸鱼,一起学习。<br> https://blog.csdn.net/sodacoco/article/details/89041308

参看资料:

https://baike.baidu.com/item/%E7%94%9F%E6%97%A5%E6%82%96%E8%AE%BA

http://www.cnblogs.com/-maybe/p/4521247.html


题目:

Sometimes some mathematical results are hard to believe. One of the common problems is the birthday paradox. Suppose you are in a party where there are 23 people including you. What is the probability that at least two people in the party have same birthday? Surprisingly the result is more than 0.5. Now here you have to do the opposite. You have given the number of days in a year. Remember that you can be in a different planet, for example, in Mars, a year is 669 days long. You have to find the minimum number of people you have to invite in a party such that the probability of at least two people in the party have same birthday is at least 0.5.

Input

Input starts with an integer T (≤ 20000), denoting the number of test cases.

Each case contains an integer n (1 ≤ n ≤ 105) in a single line, denoting the number of days in a year in the planet.

Output

For each case, print the case number and the desired result.

Sample Input

2

365

669

Sample Output

Case 1: 22

Case 2: 30

题目大意: 

       给出n,表示一年有n天,求一个人至少邀请多少个人,才可以至少有2个人同时生日的概率>=0.5;

解题思路:

       我们知道有一个有关于生日的结论:就是如果有23个人同时在一个教室,则这个教室至少有2个人同时生日的概率>50%。

       设p(i)表示教室有i个人,但是没有人同时生日的概率。

       则:p(1)=1

              i>1时:第一个人有365种选择,第2个人只有364种选择,第3个人有363种选择....

              则:p(i)=(365/365)*(364/365)*(363/365)*...*((365-i+1)/365)

                          =(265*364*...*(366-i))/(365^i);

              则当p(i)<=0.5时,至少2个人同时生日的概率为1-p(i)>=0.5;

              经过计算:当i=23时,p(23)<=0.5。

       这道题的题意:如果一年不是有365天呢?

       给出n,表示一年有n天,求一个人至少邀请多少个人,才可以至少有2个人同时生日的概率>=0.5;

       PS:

              1>邀请多少个人,所以p(i)<=0.5后,输出的是i-1;

              2>如果一年只有1天的话,需要邀请1;

              3>由于当n=10^5的时候,i只比300多一点,所以在循环的时候,直接i<=400;

实现代码:

#include<cstdio>
#include<iostream>
const int exp=1e-8;
inline int sgu(double a){
    return (a>exp ) - ( a< -exp);
}

int main(){
    int test;
    scanf("%d",&test);
    int cas=1;
    while(test--){
        int n;
        scanf("%d",&n);
        double p=1.0;
        int ans=0;
        for(int i=2;i<=400;i++){
            p=p/(double)n*(double)(n-i+1);
            if(sgu(p-0.5)<=0){
                ans=i;
                break;
            }
        }
        if(ans>1)
            ans--;
        printf("Case %d: %d\n",cas++,ans);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/sodacoco/article/details/89041308