PAT 甲级 1099 Build A Binary Search Tree(30分)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node’s key.
The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
Both the left and right subtrees must also be binary search trees.
Given the structure of a binary tree and a sequence of distinct integer keys, there is only one way to fill these keys into the tree so that the resulting tree satisfies the definition of a BST. You are supposed to output the level order traversal sequence of that tree. The sample is illustrated by Figure 1 and 2.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100) which is the total number of nodes in the tree. The next N lines each contains the left and the right children of a node in the format left_index right_index, provided that the nodes are numbered from 0 to N−1, and 0 is always the root. If one child is missing, then −1 will represent the NULL child pointer. Finally N distinct integer keys are given in the last line.

Output Specification:

For each test case, print in one line the level order traversal sequence of that tree. All the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:

9
1 6
2 3
-1 -1
-1 4
5 -1
-1 -1
7 -1
-1 8
-1 -1
73 45 11 58 82 25 67 38 42

Sample Output:

58 25 82 11 38 67 45 73 42

解题思路:通过静态链表构建树,因为二叉排序树中序遍历是顺序序列,所以将输入数据排序,中序遍历的过程中插入。最后按照层序遍历输出。

代码:

#include<cstdio>
#include<algorithm> 
#include<queue>
using namespace std;
struct node{
	int data;
	int lchild;
	int rchild;
}Node[110];
int start = 0;
int flag = 0;
int N,a[110];
void inorder(int root){
	if(Node[root].lchild != -1)
		inorder(Node[root].lchild);
	Node[root].data = a[start++];
	if(Node[root].rchild != -1)
		inorder(Node[root].rchild);
}
void layerorder(int root){
	queue<int> q;
	q.push(root);
	while(!q.empty()){
		int front = q.front();
		q.pop();
		if(flag)
			printf(" ") ;
		printf("%d",Node[front].data);
		flag = 1;
		if(Node[front].lchild!=-1)
			q.push(Node[front].lchild);
		if(Node[front].rchild!=-1)
			q.push(Node[front].rchild);
	}
}
int main(void){
	scanf("%d",&N);
	for(int i = 0;i < N;i++){
		scanf("%d %d",&Node[i].lchild,&Node[i].rchild);
	}
	for(int i = 0; i < N;i++)
		scanf("%d",&a[i]);
	sort(a,a+N);
	inorder(0);
	layerorder(0);
	return 0;
}
发布了69 篇原创文章 · 获赞 5 · 访问量 2045

猜你喜欢

转载自blog.csdn.net/lovingcgq/article/details/104525239