PAT--1099 Build A Binary Search Tree (30 分)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

Given the structure of a binary tree and a sequence of distinct integer keys, there is only one way to fill these keys into the tree so that the resulting tree satisfies the definition of a BST. You are supposed to output the level order traversal sequence of that tree. The sample is illustrated by Figure 1 and 2.

figBST.jpg

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100) which is the total number of nodes in the tree. The next N lines each contains the left and the right children of a node in the format left_index right_index, provided that the nodes are numbered from 0 to N−1, and 0 is always the root. If one child is missing, then −1will represent the NULL child pointer. Finally N distinct integer keys are given in the last line.

Output Specification:

For each test case, print in one line the level order traversal sequence of that tree. All the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:

9
1 6
2 3
-1 -1
-1 4
5 -1
-1 -1
7 -1
-1 8
-1 -1
73 45 11 58 82 25 67 38 42

Sample Output:

58 25 82 11 38 67 45 73 42

 代码:

#include <iostream>
#include <bits/stdc++.h>

using namespace std;

struct TreeNode{
    int data;
    int left,right;
}t[101];
int a[101];
int b[101];
int n;
int flag=0,k=0;
void inOrder(int x){
    if(t[x].left!=-1){
        inOrder(t[x].left);
    }
    t[x].data = a[flag++];
    if(t[x].right!=-1){
        inOrder(t[x].right);
    }
}


int main()
{
    cin>>n;

    for(int i=0;i<n;i++){
        cin>>t[i].left>>t[i].right;
    }

    for(int i=0;i<n;i++){
        cin>>a[i];
    }

    sort(a,a+n);

    inOrder(0);
    TreeNode tmp;
    queue<TreeNode> q;
    q.push(t[0]);
    while(!q.empty()){
        tmp = q.front();
        b[k++] = tmp.data;
        q.pop();
        if(tmp.left!=-1){
            q.push(t[tmp.left]);
        }
        if(tmp.right!=-1){
            q.push(t[tmp.right]);
        }
    }
    for(int i=0; i<n; i++)
    {
        if(i==0){
            cout<<b[i];
        }else{
            cout<<" "<<b[i];
        }

    }
    cout<<endl;
    return 0;
}

 分析:

 建树过程可以参照PAT--1064,刚开始不明白为什么该方法中需要在用层次遍历一遍,而1064直接建好的树就可以直接输出。好像是因为结点的左右孩子是指定的原因,在完全搜索树中,孩子就是其2*i和2*i+1,但是在此题中,孩子由输入指定。建树是定好了左右孩子,然后向结点中填充数据。(分析有点乱,因为我自己也不是特别清楚)

猜你喜欢

转载自blog.csdn.net/jackson_j/article/details/98507326