POJ1799 Yeehaa!【计算几何】

Yeehaa!
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 15477 Accepted: 6766

Description

Background
George B. wants to be more than just a good American. He wants to make his daddy proud and become a western hero. You know, like John Wayne.
But sneaky as he is, he wants a special revolver that will allow him to shoot more often than just the usual six times. This way he can fool and kill the enemy easily (at least that’s what he thinks).
Problem
George has kidnapped … uh, I mean … “invited” you and will only let you go if you help him with the math. The piece of the revolver that contains the bullets looks like this (examples for 6 and 17 bullets):
在这里插入图片描述

There is a large circle with radius R and n little circles with radius r that are placed inside on the border of the large circle. George wants his bullets to be as large as possible, so there should be no space between the circles. George will decide how large the whole revolver will be and how many bullets it shall contain.Your job is, given R and n, to compute r.

Input

The first line contains the number of scenarios. For each scenario follows a line containing a real number R and an integer n, with 1 <= R <= 100 and 2 <= n <= 100.

Output

The output for every scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. Then print the value for r, rounded to three decimal places. Terminate the output for the scenario with a blank line.

Sample Input

4
4.0 6
4.0 17
3.14159 100
42 2

Sample Output

Scenario #1:
1.333

Scenario #2:
0.621

Scenario #3:
0.096

Scenario #4:
21.000

Source

TUD Programming Contest 2004, Darmstadt, Germany

问题链接POJ1799 Yeehaa!
问题简述:给出大圆的半径,和小圆的个数,求小圆的半径。
问题分析:计算几何题,看程序代码不解释。
程序说明:(略)
参考链接:(略)
题记:(略)

AC的C++语言程序如下:

/* POJ1799 Yeehaa! */

#include <iostream>
#include <cstdio>
#include <cmath>

using namespace std;

const double PI = acos(-1.0);

int main()
{
    int t;
    double r, n;
    scanf("%d", &t);
    for(int k = 1; k <= t; k++) {
        scanf("%lf%lf", &r, &n);

        double angle = PI / n;
        double r2 = r * sin(angle) / (1 + sin(angle));

        printf("Scenario #%d:\n%.3f\n\n", k, r2);
    }

    return 0;
}
发布了2289 篇原创文章 · 获赞 2373 · 访问量 265万+

猜你喜欢

转载自blog.csdn.net/tigerisland45/article/details/105524609