POJ - 2398 Toy Storage————计算几何

Mom and dad have a problem: their child, Reza, never puts his toys away when he is finished playing with them. They gave Reza a rectangular box to put his toys in. Unfortunately, Reza is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for Reza to find his favorite toys anymore.
Reza’s parents came up with the following idea. They put cardboard partitions into the box. Even if Reza keeps throwing his toys into the box, at least toys that get thrown into different partitions stay separate. The box looks like this from the top:
这里写图片描述
We want for each positive integer t, such that there exists a partition with t toys, determine how many partitions have t, toys.
Input
The input consists of a number of cases. The first line consists of six integers n, m, x1, y1, x2, y2. The number of cardboards to form the partitions is n (0 < n <= 1000) and the number of toys is given in m (0 < m <= 1000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1, y1) and (x2, y2), respectively. The following n lines each consists of two integers Ui Li, indicating that the ends of the ith cardboard is at the coordinates (Ui, y1) and (Li, y2). You may assume that the cardboards do not intersect with each other. The next m lines each consists of two integers Xi Yi specifying where the ith toy has landed in the box. You may assume that no toy will land on a cardboard.

A line consisting of a single 0 terminates the input.
Output
For each box, first provide a header stating “Box” on a line of its own. After that, there will be one line of output per count (t > 0) of toys in a partition. The value t will be followed by a colon and a space, followed the number of partitions containing t toys. Output will be sorted in ascending order of t for each box.
Sample Input
4 10 0 10 100 0
20 20
80 80
60 60
40 40
5 10
15 10
95 10
25 10
65 10
75 10
35 10
45 10
55 10
85 10
5 6 0 10 60 0
4 3
15 30
3 1
6 8
10 10
2 1
2 8
1 5
5 5
40 10
7 9
0
Sample Output
Box
2: 5
Box
1: 4
2: 1


#include<cstdio>
#include<cmath>
#include<algorithm>
#include<iostream>
#include<cstring>
#include<vector>
#include<map>
using namespace std;
typedef long long ll;
const int MAXN=5000+5;
struct node{
    int x,y;
    node(){}
    node(int _x,int _y)
    {
        x=_x;
        y=_y;
    }
}p[MAXN];
struct line{
    node s,e;
    line(){}
    line(node _s,node _e)
    {
        s=_s;
        e=_e;
    }
}l[MAXN];

bool cmp1(node a,node b)
{
    return a.x==b.x?a.y<b.y:a.x<b.x;
}

int dir(node p1,node p2,node p3)//
{
    return (p3.x-p1.x)*(p2.y-p1.y)-(p2.x-p1.x)*(p3.y-p1.y);
}
bool cmp2(line a,line b)
{
    node n=a.s;
    node m=b.s;
    return n.x<m.x;
}
bool cmp3(int x,int y)
{
    return x>y;
}
int main()
{
    int n,m,x1,x2,y1,y2;
    int k=1;
    while(~scanf("%d",&n)&&n)
    {
//      if(k)   k=0;
//      else    printf("\n");
        int a[MAXN];
        memset(a,0,sizeof(a));
        scanf("%d %d %d %d %d",&m,&x1,&y1,&x2,&y2);
        l[0]=line(node(x1,y1),node(x1,y2));
        for(int i=1;i<=n;i++)
        {
            int x_1,x_2;
            scanf("%d %d",&x_1,&x_2);
            l[i]=line(node(x_1,y1),node(x_2,y2));
        }
        l[n+1]=line(node(x2,y1),node(x2,y2));
        for(int i=0;i<m;i++)
        {
            int x,y;
            scanf("%d %d",&x,&y);
            p[i]=node(x,y);
        }
        sort(p,p+m,cmp1);
        sort(l,l+n+2,cmp2);
        for(int i=0;i<m;i++)
        {
            for(int j=0;j<=n;j++)
            {
                if((dir(p[i],l[j].s,l[j].e)>0&&dir(p[i],l[j+1].s,l[j+1].e)<0)||(dir(p[i],l[j].s,l[j].e)<0&&dir(p[i],l[j+1].s,l[j+1].e)>0))
//              if(dir(p[i],l[j].s,l[j].e) * dir(p[i],l[j+1].s,l[j+1].e)<0)
                {
                    a[j]++;
                    break;
                }
            }
        }

        map<int,int> ma;
        for(int i=0;i<n+1;i++)
            ma[a[i]]++;

//      sort(a,a+n+1,cmp3);
        printf("Box\n");
        for(map<int,int>::iterator ite=ma.begin();ite!=ma.end();ite++)
        {
            if(ite->first==0)   continue;
            printf("%d: %d\n",ite->first,ite->second);
        }

//      for(int i=0;i<n+1;i++)
//          printf("%d: %d\n",i,a[i]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/Hpuer_Random/article/details/81350448