poj1269 intersecting lines【计算几何】

We all know that a pair of distinct points on a plane defines a line and that a pair of lines on a plane will intersect in one of three ways: 1) no intersection because they are parallel, 2) intersect in a line because they are on top of one another (i.e. they are the same line), 3) intersect in a point. In this problem you will use your algebraic knowledge to create a program that determines how and where two lines intersect. 
Your program will repeatedly read in four points that define two lines in the x-y plane and determine how and where the lines intersect. All numbers required by this problem will be reasonable, say between -1000 and 1000. 
Input
The first line contains an integer N between 1 and 10 describing how many pairs of lines are represented. The next N lines will each contain eight integers. These integers represent the coordinates of four points on the plane in the order x1y1x2y2x3y3x4y4. Thus each of these input lines represents two lines on the plane: the line through (x1,y1) and (x2,y2) and the line through (x3,y3) and (x4,y4). The point (x1,y1) is always distinct from (x2,y2). Likewise with (x3,y3) and (x4,y4).
Output
There should be N+2 lines of output. The first line of output should read INTERSECTING LINES OUTPUT. There will then be one line of output for each pair of planar lines represented by a line of input, describing how the lines intersect: none, line, or point. If the intersection is a point then your program should output the x and y coordinates of the point, correct to two decimal places. The final line of output should read "END OF OUTPUT".
Sample Input
5
0 0 4 4 0 4 4 0
5 0 7 6 1 0 2 3
5 0 7 6 3 -6 4 -3
2 0 2 27 1 5 18 5
0 3 4 0 1 2 2 5
Sample Output
INTERSECTING LINES OUTPUT
POINT 2.00 2.00
NONE
LINE
POINT 2.00 5.00
POINT 1.07 2.20
END OF OUTPUT

求交点的水题

列一下直线的解析式推一下公式就行了

需要注意的是如果用斜率式要注意斜率不存在的情况 啊我好菜我都不记得直线别的解析式要怎么搞了

嗯觉得我写题目的速度实在是太慢了 今天过来也没有要读题结果这种水题还写了这么久

#include <iostream>
#include<stdio.h>
#include<math.h>
#define inf 0x3f3f3f3f

using namespace std;

struct point{
    double x, y;
};
struct line{
    point st, ed;
    double k, b;
};

double getk(line a)
{
    point ed = a.ed, st = a.st;
    if(ed.x == st.x)return inf;
    double k = (ed.y - st.y)/ (ed.x - st.x);
    return k;
}

double getb(line a)
{
    point ed = a.ed, st = a.st;
    if(ed.x == st.x)return -inf;
    double b = st.y - st.x * a.k;
    return b;
}

point inter(line a, line b)
{
    point p1 = a.st, p2 = a.ed, p3 = b.st, p4 = b.ed;
    point in;
    in.x = (p2.x - p1.x) * (p4.x - p3.x) * (p3.y - p1.y) + (p4.x - p3.x) * (p2.y - p1.y) * p1.x - (p2.x - p1.x) * (p4.y - p3.y) * p3.x;
    in.x = in.x / ((p4.x - p3.x) * (p2.y - p1.y) - (p2.x - p1.x) * (p4.y - p3.y));
    in.y = a.k * in.x + a.b;
    return in;
}

int n;
point a, b, c, d;
line l1, l2;
int main()
{
    while(scanf("%d",&n) != EOF){
        cout<<"INTERSECTING LINES OUTPUT\n";
        for(int i = 0; i < n; i++){
            cin>>a.x>>a.y>>b.x>>b.y>>c.x>>c.y>>d.x>>d.y;
            l1.st = a;l1.ed = b;
            l2.st = c;l2.ed = d;
            l1.k = getk(l1);l1.b = getb(l1);
            l2.k = getk(l2);l2.b = getb(l2);
            if(l1.k == l2.k){
                if(l1.k == inf){
                    if(l1.st.x == l2.st.x){
                        cout<<"LINE\n";
                    }
                    else{
                        cout<<"NONE\n";
                    }
                }
                else if(l1.b == l2.b){
                    cout<<"LINE\n";
                }
                else{
                    cout<<"NONE\n";
                }
            }
            else if(l1.k == inf){
                point ans;
                ans.x = l1.st.x;
                ans.y = l2.k * ans.x + l2.b;
                printf("POINT %.2f %.2f\n", ans.x, ans.y);
            }
            else if(l2.k == inf){
                point ans;
                ans.x = l2.st.x;
                ans.y = l1.k * ans.x + l1.b;
                printf("POINT %.2f %.2f\n", ans.x, ans.y);
            }
            else{
                point ans = inter(l1, l2);
                printf("POINT %.2f %.2f\n", ans.x, ans.y);
            }

        }
        cout<<"END OF OUTPUT\n";
    }
    return 0;
}


猜你喜欢

转载自blog.csdn.net/wybooooooooo/article/details/79872492