Euclid's Game (博弈--有两种选择的人必赢 )

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6259 Accepted Submission(s): 2939

Problem Description
Two players, Stan and Ollie, play, starting with two natural numbers. Stan, the first player, subtracts any positive multiple of the lesser of the two numbers from the greater of the two numbers, provided that the resulting number must be nonnegative. Then Ollie, the second player, does the same with the two resulting numbers, then Stan, etc., alternately, until one player is able to subtract a multiple of the lesser number from the greater to reach 0, and thereby wins. For example, the players may start with (25,7):

25 7
11 7
4 7
4 3
1 3
1 0

an Stan wins.

Input
The input consists of a number of lines. Each line contains two positive integers giving the starting two numbers of the game. Stan always starts.

Output
For each line of input, output one line saying either Stan wins or Ollie wins assuming that both of them play perfectly. The last line of input contains two zeroes and should not be processed.

Sample Input
34 12
15 24
0 0

Sample Output
Stan wins
Ollie wins

Source
University of Waterloo Local Contest 2002.09.28

Recommend
LL

//有两种选择的人必赢 -------- 胜者总能支配别人的路!!!

#pragma warning(disable:4996)
#include"iostream"
#include"functional"
#include"algorithm"
#include"cstring"
#include"stack"
#include"cmath"
#include"queue"
#include"vector"
#include"map"
typedef long long int ll;
using namespace std;
int main(){
	ll a,b;
	while(cin>>a>>b){
		if(a==0&&b==0) break;
		if(a<b) swap(a,b);
		if(a>=2*b){
			cout<<"Stan wins"<<endl;
			continue;
		}	
		ll flag=0;
		while(1){
			if(a>=b*2||a%b==0){
				break;
			}
			flag++;
			a-=b;
			if(a<b) swap(a,b);
		}
		if(flag%2)cout<<"Ollie wins"<<endl;
		else{
			cout<<"Stan wins"<<endl;
		} 
	}
} 
发布了49 篇原创文章 · 获赞 0 · 访问量 660

猜你喜欢

转载自blog.csdn.net/qq_14989799/article/details/105399790