1093 Count PAT's(25 分)

版权声明:版权声明:本文为博主原创文章,未经博主允许不得转载 @爬动的小蜗牛 https://blog.csdn.net/qq_34649947/article/details/82109094

1093 Count PAT's(25 分)

The string APPAPT contains two PAT's as substrings. The first one is formed by the 2nd, the 4th, and the 6th characters, and the second one is formed by the 3rd, the 4th, and the 6th characters.

Now given any string, you are supposed to tell the number of PAT's contained in the string.

Input Specification:

Each input file contains one test case. For each case, there is only one line giving a string of no more than 10​5​​ characters containing only PA, or T.

Output Specification:

For each test case, print in one line the number of PAT's contained in the string. Since the result may be a huge number, you only have to output the result moded by 1000000007.

Sample Input:

APPAPT

Sample Output:

2

主要就是利用累加的思想,这样不容易超时。

#include <bits/stdc++.h>
using namespace std;
const int maxn = 100000 + 10;
const int MOD = 1000000007;
int main() {
    string cas;
    cin >> cas;
    int ans = 0;
    int ansp = 0, ansa = 0;
    for (int i = 0; i < cas.length(); i++) {
        if (cas[i] == 'P') {
            ansp++;
        }
        else if (cas[i] == 'A') {
            ansa = (ansa + ansp)%MOD;
        }
        else {
            ans = (ans + ansa)%MOD;
        }
    }
    cout << ans%MOD << endl;
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_34649947/article/details/82109094