抓奶牛(广搜)

题目
O - Catch That Cow
Time Limit:2000MS    Memory Limit:65536KB    64bit IO Format:%I64d & %I64u
use MathJax to parse formulas

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
大意

广搜的题目,人在n坐标,牛在m坐标,问如何用最短时间抓到奶牛,每次都可以向前走一步或向后走一步或者飞到2倍的这个点这里

思路

找一个标记数组 记录用了多少分钟 初始化为0 用队列来实现
一开始一直1 100000这组样例不出结果


代码
#include <iostream>
#include <stdio.h>
#include <queue>
#include<string.h>
using namespace std;
int a[100005];
int bfs(int n,int m)
{
        queue <int> q;     //这样可以不用清空队列了
        int next,head;
        q.push(n);
        a[n]=1;

        while(q.size())
        {
            head=q.front();
            q.pop();
            for(int i=0;i<3;i++)
            {
                if(i==0)
                    next=head-1;
                else if(i==1)
                    next=head+1;
                else
                    next=head*2;
                if(next<0||next>=100001)    //一开始一直写的100000导致不对
                    continue;
                if(a[next]==0)
                {
                    q.push(next);
                    a[next]=a[head]+1;
                }
                if(next==m)
                    return a[next];
            }
        }
}
int main()
{
    int n,m,ans,topp;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        memset(a,0,sizeof(a));

        if(n>=m)
           printf("%d\n",n-m);
        else
            printf("%d\n",bfs(n,m)-1);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41700151/article/details/80084917