1036 Boys vs Girls (25分)【元素查找】

 1036 Boys vs Girls (25分)

This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N lines of student information. Each line contains a student's namegenderID and grade, separated by a space, where name and ID are strings of no more than 10 characters with no space, gender is either F (female) or M (male), and grade is an integer between 0 and 100. It is guaranteed that all the grades are distinct.

Output Specification:

For each test case, output in 3 lines. The first line gives the name and ID of the female student with the highest grade, and the second line gives that of the male student with the lowest grade. The third line gives the difference grade​F​​−grade​M​​. If one such kind of student is missing, output Absent in the corresponding line, and output NA in the third line instead.

Sample Input 1:

3
Joe M Math990112 89
Mike M CS991301 100
Mary F EE990830 95

Sample Output 1:

Mary EE990830
Joe Math990112
6

Sample Input 2:

1
Jean M AA980920 60

Sample Output 2:

Absent
Jean AA980920
NA

解题思路:

比较简单的一道题目,利用结构体对性别和成绩进行排序。 

#include<iostream>
#include<string>
#include<math.h>
#include<algorithm>
using namespace std;

struct Stu {
	int grade;
	string gender;
	string id;
	string name;
}stu[1010];

int cmp(Stu a, Stu b)
{
	if (a.gender == b.gender)
		return a.grade > b.grade;
	else return a.gender < b.gender;
}

int main()
{
	int n;
	cin >> n;
	int male = 0, female = 0;
	for (int i = 0; i < n; i++)
	{
		cin >> stu[i].name >> stu[i].gender >> stu[i].id >> stu[i].grade;
		if (stu[i].gender == "F")
			female++;
		else male++;
	}
	sort(stu, stu + n, cmp);
	if (female != 0)
		cout << stu[0].name<< " " << stu[0].id << endl;
	else cout << "Absent" << endl;
	if (male != 0)
		cout << stu[n - 1].name << " " << stu[n - 1].id << endl;
	else cout << "Absent" << endl;
	if (female == 0 || male == 0)
		cout << "NA" << endl;
	else cout << abs(stu[0].grade - stu[n - 1].grade) << endl;
	return 0;
}
发布了119 篇原创文章 · 获赞 22 · 访问量 1万+

猜你喜欢

转载自blog.csdn.net/lovecyr/article/details/104627972