1038 Recover the Smallest Number (30point(s))

文章目录

问题

Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given { 32, 321, 3214, 0229, 87 }, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.
Input Specification:

Each input file contains one test case. Each case gives a positive integer N (≤10​4​​) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.
Output Specification:

For each test case, print the smallest number in one line. Notice that the first digit must not be zero.
Sample Input:

5 32 321 3214 0229 87

Sample Output:

22932132143287

解决方法

分析:贪心算法
根据测试案例看,这个题似乎是一个字符串按照字典序排序。但是从输出案例 32 321 它的输出是32132.所以这里是按照组合的字母串更小排序。

#include<iostream>
#include<algorithm>
#include<vector>
#include<string>
using namespace std;
bool cmp(string s, string t)
{
	return s+t<t+s;
}
int main()
{
	int n;
	scanf("%d", &n);
	string result;
	vector<string>v;
	for (int i = 0; i < n; i++)
	{
		string s;
		cin >> s;
		v.push_back(s);
	}
	sort(v.begin(), v.end(),cmp);
	for (int i = 0; i < v.size(); i++)	result += v[i];
	while (result.size() != 0 && result[0] == '0')	result.erase(result.begin());
	if (result.size() == 0) cout << 0;
	else cout << result;
	return 0;
}

后记

如果erase之后发现result.size()为0,说明这个数就是0.

发布了235 篇原创文章 · 获赞 3 · 访问量 4590

猜你喜欢

转载自blog.csdn.net/weixin_43725617/article/details/104692247
今日推荐