1038 Recover the Smallest Number (30 分)

版权声明:本文为博主原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。
本文链接: https://blog.csdn.net/chen_zan_yu_/article/details/102648850

1038 Recover the Smallest Number (30 分)

Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given { 32, 321, 3214, 0229, 87 }, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.

Input Specification:

Each input file contains one test case. Each case gives a positive integer N (≤10​4​​) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the smallest number in one line. Notice that the first digit must not be zero.

Sample Input:

5 32 321 3214 0229 87

Sample Output:

22932132143287
#include <bits/stdc++.h>
using namespace std;
const int maxn=10010;
string str[maxn];
bool cmp(string a,string b)
{
    return a+b<b+a;
}
int main()
{
    int n;
    scanf("%d",&n);
    for(int i=0; i<n; i++)
    {
        cin>>str[i];
    }
    sort(str,str+n,cmp);
    string ans;
    for(int i=0; i<n; i++)
    {
        ans+=str[i];
    }
    while(ans.size()!=0&&ans[0]=='0')
    {
        ans.erase(ans.begin());
    }
    if(ans.size()==0)
        printf("0\n");
    else
    {
        cout<<ans<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/chen_zan_yu_/article/details/102648850