1038 Recover the Smallest Number (30分)【贪心】

1038 Recover the Smallest Number (30分)

Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given { 32, 321, 3214, 0229, 87 }, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.

Input Specification:

Each input file contains one test case. Each case gives a positive integer N (≤10​4​​) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the smallest number in one line. Notice that the first digit must not be zero.

Sample Input:

5 32 321 3214 0229 87

Sample Output:

22932132143287

题目大意:

给出若干可能有前导0的字符串,将他们按照某个顺序拼接,使得生成的数最小。

解题思路:

这道题目可以对字符串进行排序来求解,但注意,并不是单纯的string1<string2即可。例如对于:“32”和“321”,排序的结果是{“32”,“321”} = 32321,但实际更小的是32132。

实际的贪心策略是string1+string2<string2+string1。 

#include<iostream>
#include<string>
#include<algorithm>
using namespace std;
string str[10010];

int cmp(string a, string b)
{
	return a + b < b + a;
}
int main()
{
	int n;
	cin >> n;
	for (int i = 0; i < n; i++)
	{
		cin >> str[i];
	}
	sort(str, str + n, cmp);
	string ans = "";
	for (int i = 0; i < n; i++)
	{
		ans += str[i];
	}
	while (ans.size() != 0 && ans[0] == '0')
	{
		ans.erase(ans.begin());                 //注意去除前导零
	}
	if (ans.size() == 0)
		cout << 0 <<endl;
	else cout << ans << endl;
	return 0;
}
发布了119 篇原创文章 · 获赞 22 · 访问量 1万+

猜你喜欢

转载自blog.csdn.net/lovecyr/article/details/104774475