POJ 3311 Hie with the Pie (弗洛伊德/TSP/状态压缩)

Hie with the Pie (POJ3311)

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 8639 Accepted: 4722
Description

The Pizazz Pizzeria prides itself in delivering pizzas to its customers as fast as possible. Unfortunately, due to cutbacks, they can afford to hire only one driver to do the deliveries. He will wait for 1 or more (up to 10) orders to be processed before he starts any deliveries. Needless to say, he would like to take the shortest route in delivering these goodies and returning to the pizzeria, even if it means passing the same location(s) or the pizzeria more than once on the way. He has commissioned you to write a program to help him.

Input

Input will consist of multiple test cases. The first line will contain a single integer n indicating the number of orders to deliver, where 1 ≤ n ≤ 10. After this will be n + 1 lines each containing n + 1 integers indicating the times to travel between the pizzeria (numbered 0) and the n locations (numbers 1 to n). The jth value on the ith line indicates the time to go directly from location i to location j without visiting any other locations along the way. Note that there may be quicker ways to go from i to j via other locations, due to different speed limits, traffic lights, etc. Also, the time values may not be symmetric, i.e., the time to go directly from location i to j may not be the same as the time to go directly from location j to i. An input value of n = 0 will terminate input.

Output

For each test case, you should output a single number indicating the minimum time to deliver all of the pizzas and return to the pizzeria.

Sample Input

3
0 1 10 10
1 0 1 2
10 1 0 10
10 2 10 0
0
Sample Output

8

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int n;
int dp[1<<11][12];
int dis[12][12];
int ans;
int main(){
    while(~scanf("%d",&n)&&n){
        for(int i = 0; i <= n; i++){
            for(int j = 0; j <= n; j++){
                scanf("%d",&dis[i][j]);
            }
        }
        //弗洛伊德算法计算两点间的最短距离
        for(int k = 0; k <= n; k++){
            for(int i = 0; i <= n; i++){
                for(int j = 0; j <= n; j++){
                    if(dis[i][k] + dis[k][j] < dis[i][j]){
                        dis[i][j] = dis[i][k] + dis[k][j];
                    }
                }
            }
        }
        for(int state = 0; state < (1 << n); state ++){//枚举所有状态,用位运算表示
            for(int i = 1; i <= n; i++){
                if(state & (1<<(i-1))){//状态state中已经经过城市i
                    if(state == (1<<(i-1))){////状态State只经过城市i,最优解自然是从0出发到i的dis,这也是DP的边界
                        dp[state][i] = dis[0][i];
                    }
                    else{//如果state经过多个城市
                        dp[state][i] = 0x7fffffff;
                        for(int j = 1; j <= n; j++){
                            if(state&(1<<(j-1)) && j!=i ){
                                dp[state][i] = min(dp[state][i],dp[state^(1<<(i-1))][j]+dis[j][i]);
                            }
                        }
                    }
                }
            }
        }
        ans = dp[(1<<n)-1][1]+dis[1][0];
        for(int i =2; i <= n; i++){
            ans = min(ans,dp[(1<<n)-1][i]+dis[i][0]);//从i点回到0点
        }
        printf("%d\n",ans);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/jal517486222/article/details/79357740