Hie with the Pie(状压dp+floyd)

Description

The Pizazz Pizzeria prides itself in delivering pizzas to its customers as fast as possible. Unfortunately, due to cutbacks, they can afford to hire only one driver to do the deliveries. He will wait for 1 or more (up to 10) orders to be processed before he starts any deliveries. Needless to say, he would like to take the shortest route in delivering these goodies and returning to the pizzeria, even if it means passing the same location(s) or the pizzeria more than once on the way. He has commissioned you to write a program to help him.

Input

Input will consist of multiple test cases. The first line will contain a single integer n indicating the number of orders to deliver, where 1 ≤ n ≤ 10. After this will be n + 1 lines each containing n + 1 integers indicating the times to travel between the pizzeria (numbered 0) and the n locations (numbers 1 to n). The j-th value on the i-th line indicates the time to go directly from location ito location j without visiting any other locations along the way. Note that there may be quicker ways to go from i to j via other locations, due to different speed limits, traffic lights, etc. Also, the time values may not be symmetric, i.e., the time to go directly from location i to j may not be the same as the time to go directly from location j  to i. An input value of n = 0 will terminate input.

Output

For each test case, you should output a single number indicating the minimum time to deliver all of the pizzas and return to the pizzeria.

Sample Input

3
0 1 10 10
1 0 1 2
10 1 0 10
10 2 10 0
0

Sample Output

8

Source

题意:有n+1个点,点与点距离的邻接矩阵,求从起点经过所有顶点又回到起点的最短距离

#include <cstdio>
#include <cstring>
const int INF=0x3f3f3f3f;
int dis[12][12];
int dp[1<<11][12];
int n;
int main()
{
    while(~scanf("%d",&n),n)
    {
        for(int i=0;i<=n;i++)
            for(int j=0;j<=n;j++)
               scanf("%d",&dis[i][j]);
        for(int k=0;k<=n;k++)
            for(int i=0;i<=n;i++)
              for(int j=0;j<=n;j++)
                 if(dis[i][k]+dis[k][j]<dis[i][j])//
                     dis[i][j]=dis[i][k]+dis[k][j];
      for(int s=0;s<=(1<<n)-1;s++)//枚举所有状态000 001 010 011 100 101 110 111,
         for(int i=1;i<=n;i++)
            if(s&(1<<(i-1)))//判断经过那一点
      {
          if(s==(1<<(i-1)))//只经过一点i时
            dp[s][i]=dis[0][i];
          else//经过多个点到达i
          {
              dp[s][i]=INF;
              for(int j=1;j<=n;j++)
                if(s&(1<<(j-1))&&j!=i)//把除i外所经过的点
                  if(dp[s^(1<<(i-1))][j]+dis[j][i]<dp[s][i])//把除i外的其他点加入集合中
                    dp[s][i]=dp[s^(1<<(i-1))][j]+dis[j][i];

          }
      }
    int sum=dp[(1<<n)-1][1]+dis[1][0];//注意1<<n-1,1<<n必须加括号,否则出错
    for(int i=2;i<=n;i++)
         if(dp[(1<<n)-1][i]+dis[i][0]<sum)
           sum=dp[(1<<n)-1][i]+dis[i][0];
    printf("%d\n",sum);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/honeycomb_1/article/details/80574758