矩阵乘法------斐波那契前 n 项和

大家都知道 Fibonacci 数列吧,f1=1,f2=1,f3=2,f4=3,…,fn=fn−1+fn−2f1=1,f2=1,f3=2,f4=3,…,fn=fn−1+fn−2

。现在问题很简单,输入 nn

和 mm

,求 fnfn

的前 nn

项和 SnmodmSnmodm

。输入格式共一行,包含两个整数 nn

和 mm

。输出格式输出前 nn

项和 SnmodmSnmodm

的值。数据范围1≤n≤20000000001≤n≤2000000000

,
1≤m≤10000000101≤m≤1000000010

输入样例:5 1000
输出样例:12

思路:矩阵乘法,f数组表示的是fn, fn+1, s,先求出a数组
再写出俩个矩阵乘法的函数

#include <iostream> 
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
typedef long long LL;
const int N = 3;
int n, m;
void mul(int c[], int a[], int b[][N]){
 int temp[N] = {0};
 for (int i = 0; i < N; i ++)
   for (int j = 0; j < N; j ++)
     temp[i] = (temp[i] + (LL)a[j] * b[j][i]) % m;
     memcpy(c, temp, sizeof temp);
}
void mul(int c[][N], int a[][N], int b[][N]){
 int temp[N][N] = {0};
 for (int i = 0; i < N; i ++)
   for (int j = 0; j < N; j ++)
      for (int k = 0; k < N; k ++)
        temp[i][j] = (temp[i][j] + (LL)a[i][k] * b[k][j]) % m;
 memcpy(c, temp, sizeof temp);
}
int main(){
 cin >> n >> m;
 int f1[N] = {1, 1, 1};
 int a[N][N] = {
  {0, 1, 0},
  {1, 1, 1},
  {0, 0, 1},
 };
  n --;
 while(n){
  if (n & 1)   mul(f1, f1, a);
  mul(a, a, a);
  n >>= 1;
 }
  cout << f1[2] << endl;
  return 0;
}
发布了106 篇原创文章 · 获赞 67 · 访问量 5414

猜你喜欢

转载自blog.csdn.net/qq_45772483/article/details/105030223