复杂DP——斐波那契数列的前n项和

基本思路 (矩阵快速幂)

大家都知道 Fibonacci 数列吧,f1=1,f2=1,f3=2,f4=3,…,fn=fn−1+fn−2。

现在问题很简单,输入 n 和 m,求 fn 的前 n 项和 Snmodm。

输入格式

共一行,包含两个整数 n 和 m。

输出格式

输出前 n 项和 Snmodm 的值。

数据范围

1≤n≤2000000000,
1≤m≤1000000010

输入样例:

5 1000

输出样例:

12

思路

在这里插入图片描述

代码

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
using namespace std;

typedef long long LL;

const int N = 3;

int n,m;

void mul(int c[],int a[],int b[][N])  //一单一双
{
    int temp[N] = {0};
    for(int i = 0;i < N;i++)
        for(int j = 0;j < N;j++)
            temp[i] = (temp[i] + (LL)a[j] * b[j][i]) % m;  //矩阵运算
    memcpy(c,temp,sizeof temp);
}


void mul(int c[][N],int a[][N],int b[][N])   //两双
{
    int temp[N][N] = {0};
    for(int i = 0;i < N;i++)
        for(int j = 0;j < N;j++)
            for(int k = 0;k < N;k++)
                temp[i][j] = (temp[i][j] + (LL)a[i][k]  * b[k][j]) % m;
    memcpy(c,temp,sizeof temp);
}


int main()
{
     cin >> n >> m;
     int f1[N] = {1,1,1};
     int a[N][N] = {
         {0,1,0},
         {1,1,1},
         {0,0,1}
     };
     
     n--;
     while(n)  //快速幂算法
     {
         if(n & 1)  mul(f1,f1,a);  //res = res * a
         mul(a,a,a);  //a = a * a
         n >>=  1;
     }
     
     cout << f1[2] << endl;
    
     return 0;
}
void mul(int c[][N],int a[][N],int b[][N])   //两双
{
    int temp[N][N] = {0};
    for(int i = 0;i < N;i++)
        for(int j = 0;j < N;j++)
            for(int k = 0;k < N;k++)
                temp[i][j] = (temp[i][j] + (LL)a[i][k]  * b[k][j]) % m;
    memcpy(c,temp,sizeof temp);
}


int main()
{
     cin >> n >> m;
     int f1[N] = {1,1,1};
     int a[N][N] = {
         {0,1,0},
         {1,1,1},
         {0,0,1}
     };
     
     n--;
     while(n)  //快速幂算法
     {
         if(n & 1)  mul(f1,f1,a);  //res = res * a
         mul(a,a,a);  //a = a * a
         n >>=  1;
     }
     
     cout << f1[2] << endl;
    
     return 0;
}
发布了14 篇原创文章 · 获赞 1 · 访问量 471

猜你喜欢

转载自blog.csdn.net/ironman321/article/details/105029472