山东省第八届ACM省赛题目

Parity check

Time Limit: 2000 ms Memory Limit: 524288 KiB

Problem Description

Fascinated with the computer games, Gabriel even forgets to study. Now she needs to finish her homework, and there is an easy problem:

f(n)=

She is required to calculate f(n) mod 2 for each given n. Can you help her?

Input

Multiple test cases. Each test case is an integer n(0≤n) in a single line.

Output

For each test case, output the answer of f(n)mod2.

Sample Input

2

Sample Output

1

Hint

Source

“浪潮杯”山东省第八届ACM大学生程序设计竞赛(感谢青岛科技大学)


题解:

#include<bits/stdc++.h>
using namespace std;
int main()
{
	char str[1005];
	while(scanf("%s",str)!=EOF)
	{
		int len=strlen(str);
		int sum = 0,pre = 0; 
		for(int i = 0;i<len;i++)
		{
			sum = sum+(str[i]-'0');
		}
		if(sum%3==0)printf("0\n");
		else printf("1\n");
	}
	return  0;
} 



sum of power

Time Limit: 1000 ms Memory Limit: 65536 KiB

Problem Description

Calculate  mod (1000000000+7) for given nm.

Input

Input contains two integers n,m(1≤n≤1000,0≤m≤10).

Output

Output the answer in a single line.

Sample Input

10 0

Sample Output

10

Hint

Source

“浪潮杯”山东省第八届ACM大学生程序设计竞赛(感谢青岛科技大学)

代码:

#include<bits/stdc++.h>
using namespace std;
const long long mod = 1000000000+7;
long long quik_pow(long long a,long long m)
{
	long long  ans = 1;
	while(m)
	{
		if(m%2==1) ans  = (ans * a) % mod ;
		m = m/2 ;
		a = (a*a)%mod ;
	}
	return ans ;
}
int main()
{
	long long n,m;
	scanf("%lld%lld",&n,&m);
	long long sum = 0;
	for(long long i =1;i<=n;i++){
		sum+=quik_pow(i,m);
		sum = sum%mod;
	}
	cout<<sum<<endl;
	return  0;
} 

猜你喜欢

转载自blog.csdn.net/galesaur_wcy/article/details/80180877