fireworks(组合数取模,第八届山东省赛)

fireworks

Problem Description

Hmz likes to play fireworks, especially when they are put regularly.
Now he puts some fireworks in a line. This time he put a trigger on each firework. With that trigger, each firework will explode and split into two parts per second, which means if a firework is currently in position x, then in next second one part will be in position x−1 and one in x+1. They can continue spliting without limits, as Hmz likes.
Now there are n fireworks on the number axis. Hmz wants to know after T seconds, how many fireworks are there in position w?

Input

Input contains multiple test cases.
For each test case:

  • The first line contains 3 integers n,T,w(n,T,|w|≤10^5)
  • In next n lines, each line contains two integers xi and ci, indicating there are ci fireworks in position xi at the beginning(ci,|xi|≤10^5).

Output

For each test case, you should output the answer MOD 1000000007.

Sample Input

1 2 0
2 2
2 2 2
0 3
1 2

Sample Output

2
3

Hint

Source

“浪潮杯”山东省第八届ACM大学生程序设计竞赛(感谢青岛科技大学)

题意

烟花在每秒都会分裂一次,并且分裂成的两半刚好落在相邻的两点,然后它们也可以继续分裂。

给出 n 个点烟花的初始数量,问经过 T 秒后在点 w 有多少数量的烟花。

思路

考虑所有的烟花分裂都是一样的,并且其分裂之后所形成的局势仅和时间有关。

所以我们只需要关心一个烟花是如何分裂的:

0 0 0 0 0 1 0 0 0 0 0
0 0 0 0 1 0 1 0 0 0 0
0 0 0 1 0 2 0 1 0 0 0
0 0 1 0 3 0 3 0 1 0 0
0 1 0 4 0 6 0 4 0 1 0
Null

第几行代表第几秒,行中的每个数字代表当前时间该点烟花的数量,于是我们发现了一个中间插入了 0 的杨辉三角,计算方法也就是组合数咯~

从上面的矩阵我们可以发现,当时间与距离同奇偶的时候才处于杨辉三角中,其余情况都为 0


因为题目中数据比较大,所以计算组合数需要用到乘法逆元,先打表求出 n! ,然后根据组合数公式计算即可。也可用卢卡斯定理求组合数取模。

如果从如果在距离和时间奇偶相同的情况下,也就是所求位置个数需要用组合数求,以中心为起点组合数为C(t,(t+距离)/2);

code:

#include <bits/stdc++.h>
using namespace std;
const int mod = 1e9+7;
typedef long long ll;
ll fac[110000];
void init(){
    fac[0] = fac[1] = 1;
    for(int i = 2; i <= 100000; i++){
       fac[i] = (fac[i-1] * i) % mod;
    }
}
ll q_pow(ll a,ll b){
    ll ans = 1;
    while(b){
        if(b & 1)
            ans = ans * a % mod;
        b >>= 1;
        a = a * a % mod;
    }
    return ans % mod;
}
ll C(ll n,ll m){
    if(m > n) return 0;
    return fac[n] * q_pow(fac[m] * fac[n-m], mod - 2) % mod;
}
ll Lucas(ll n,ll m){
    if(m == 0) return 1;
    else return (C(n%mod,m%mod) * Lucas(n/mod,m/mod)) % mod;
}
int main(){
    init();
    int n,t,w;
    while(scanf("%d%d%d",&n,&t,&w)){
        ll ans = 0;
        for(int i = 0; i < n; i++){
            ll x,c;
            scanf("%lld%lld",&x,&c);
            ll k = abs(w-x);
            if((k & 1) == (t & 1) && k <= t)
                ans = (ans + (c * Lucas(t,(k+t)/2)) % mod) % mod;
        }
        printf("%lld\n",ans);
    }
    return 0;
}



猜你喜欢

转载自blog.csdn.net/codeswarrior/article/details/80185169
今日推荐