找寻环节之循环小数

CB上面的题 推一下样例很快就能找到思路

题目当中给的都是可以计算出结果的循环小数
The decimal expansion of the fraction 1/33 is 0.03, where the 03 is used to indicate that the cycle 03
repeats indefinitely with no intervening digits. In fact, the decimal expansion of every rational number
(fraction) has a repeating cycle as opposed to decimal expansions of irrational numbers, which have no
such repeating cycles.
Examples of decimal expansions of rational numbers and their repeating cycles are shown below.
Here, we use parentheses to enclose the repeating cycle rather than place a bar over the cycle.

在这里插入图片描述
Write a program that reads numerators and denominators of fractions and determines their repeating
cycles.
For the purposes of this problem, define a repeating cycle of a fraction to be the first minimal length
string of digits to the right of the decimal that repeats indefinitely with no intervening digits. Thus
for example, the repeating cycle of the fraction 1/250 is 0, which begins at position 4 (as opposed to 0
which begins at positions 1 or 2 and as opposed to 00 which begins at positions 1 or 4).
Input
Each line of the input file consists of an integer numerator, which is nonnegative, followed by an integer
denominator, which is positive. None of the input integers exceeds 3000. End-of-file indicates the end
of input.
Output
For each line of input, print the fraction, its decimal expansion through the first occurrence of the cycle
to the right of the decimal or 50 decimal places (whichever comes first), and the length of the entire
repeating cycle.
In writing the decimal expansion, enclose the repeating cycle in parentheses when possible. If the
entire repeating cycle does not occur within the first 50 places, place a left parenthesis where the cycle
begins — it will begin within the first 50 places — and place ‘…)’ after the 50th digit.

Sample Input
76 25
5 43
1 397
Sample Output
76/25 = 3.04(0)
   1 = number of digits in repeating cycle
   
5/43 = 0.(116279069767441860465)
   21 = number of digits in repeating cycle
   
1/397 = 0.(00251889168765743073047858942065491183879093198992...)
   99 = number of digits in repeating cycle///////一定要注意格式 不然会PE到你怀疑人生
#include<bits/stdc++.h>
#define mem(a,b) memset(a,b,sizeof(a))
#define LL long long
#define inf 0x3f3f3f3f
using namespace std;

const int maxn=1e4;

int m,n;
int vis[maxn];
int xiaoshu[maxn],a[maxn];
int main()
{
    while(scanf("%d%d",&m,&n)!=EOF)
    {
        int i,j;
        int x=m,y=n;
        mem(vis,0);
        int ys=0,cs=0,tot=0,xlen=0;
        while(1)
        {
            cs=m/n;//除数
            ys=m%n;//余数
            xiaoshu[++tot]=cs;
            //cout<<xiaoshu[tot]<<endl;
            a[tot]=ys;
            if(vis[ys]||ys==0)
                break;
            m=ys*10;
            vis[ys]=1;//余数重复出现或者余数为零
        }
        if(ys==0)
        {
            printf("%d/%d = %d.",x,y,xiaoshu[1]);
            for(i=2; i<=tot; i++)
                printf("%d",xiaoshu[i]);
            printf("(0)\n");
            xlen=1;
        }
        else
        {
            printf("%d/%d = %d.",x,y,xiaoshu[1]);
            for(i=1; i<=tot; i++)
            {
                if(a[i]==ys)
                    break;
            }
            if(i==1)
                xlen=tot-1;
            else
                xlen=tot-i;
            if(xlen<=50)
            {
                j=tot-xlen;
                if(j==1)
                {
                     putchar('(');
                     for(i=2;i<=tot;i++)
                        printf("%d",xiaoshu[i]);
                }
                else
                {
                    for(i=2;i<=tot;i++)
                    {
                        printf("%d",xiaoshu[i]);
                        if(i==j)
                            putchar('(');
                    }
                }
                printf(")\n");
            }
            else
            {
                j=tot-xlen;
                if(j==1)
                {
                    putchar('(');
                    for(i=2;i<=tot;i++)
                    {
                        printf("%d",xiaoshu[i]);
                        if(i==51)
                            break;
                    }
                }
                else
                {
                    for(i=2;i<=tot;i++)
                    {
                        printf("%d",xiaoshu[i]);
                        if(i==j)
                            putchar('(');
                        if(i==j+50)
                            break;
                    }
                }
                puts("...)");
            }
        }
        printf("   %d = number of digits in repeating cycle\n",xlen);
            cout<<endl;
    }
    return 0;
}
/*
3 7
1 6
5 7
1 250
300 31
655 990
76 25
5 43
1 397
*/
发布了30 篇原创文章 · 获赞 8 · 访问量 1290

猜你喜欢

转载自blog.csdn.net/qq_33961229/article/details/97955750