poj 1083

本来以为是一道贪心的裸题,类似于能看多少喜欢的电视节目那道经典题,但重要的是下面这张图,理解错误还是wa了一次,虽然理解之后很水,不过过程很重要

Moving Tables
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 32263   Accepted: 10787

Description

The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure. 

The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving. 

For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager's problem.

Input

The input consists of T test cases. The number of test cases ) (T is given in the first line of the input file. Each test case begins with a line containing an integer N , 1 <= N <= 200, that represents the number of tables to move. 
Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t each room number appears at most once in the N lines). From the 3 + N -rd 
line, the remaining test cases are listed in the same manner as above.

Output

The output should contain the minimum time in minutes to complete the moving, one per line.

Sample Input

3 
4 
10 20 
30 40 
50 60 
70 80 
2 
1 3 
2 200 
3 
10 100 
20 80 
30 50 

Sample Output

10
20
30
#include<iostream>
#include<string>
#include<string.h>
using namespace std;
#include<algorithm> 
#include<math.h>

int a[210];
int main()
{
	
	int T;
	scanf("%d",&T);
	while(T--)
	{
		int n;
		scanf("%d",&n);
		memset(a,0,sizeof(a));
		int x,y;
		for(int i=0;i<n;i++)
		{
			scanf("%d %d",&x,&y);	
			if(x>y)
				swap(x,y);
			int start=(x-1)/2;
			int end=(y-1)/2;
			for(int j=start;j<=end;j++)
			a[j]+=10;
		}
		int ans=0;
		for(int i=0;i<200;i++)
		{
			ans=max(ans,a[i]);
		}
		cout<<ans<<endl;
	}
	return 0;
 } 


发布了19 篇原创文章 · 获赞 15 · 访问量 1780

猜你喜欢

转载自blog.csdn.net/ned158/article/details/77649297
今日推荐