POJ1087 A Plug for UNIX

题目链接

http://poj.org/problem?id=1087

题目

You are in charge of setting up the press room for the inaugural meeting of the United Nations Internet eXecutive (UNIX), which has an international mandate to make the free flow of information and ideas on the Internet as cumbersome and bureaucratic as possible.
Since the room was designed to accommodate reporters and journalists from around the world, it is equipped with electrical receptacles to suit the different shapes of plugs and voltages used by appliances in all of the countries that existed when the room was built. Unfortunately, the room was built many years ago when reporters used very few electric and electronic devices and is equipped with only one receptacle of each type. These days, like everyone else, reporters require many such devices to do their jobs: laptops, cell phones, tape recorders, pagers, coffee pots, microwave ovens, blow dryers, curling
irons, tooth brushes, etc. Naturally, many of these devices can operate on batteries, but since the meeting is likely to be long and tedious, you want to be able to plug in as many as you can.
Before the meeting begins, you gather up all the devices that the reporters would like to use, and attempt to set them up. You notice that some of the devices use plugs for which there is no receptacle. You wonder if these devices are from countries that didn’t exist when the room was built. For some receptacles, there are several devices that use the corresponding plug. For other receptacles, there are no devices that use the corresponding plug.
In order to try to solve the problem you visit a nearby parts supply store. The store sells adapters that allow one type of plug to be used in a different type of outlet. Moreover, adapters are allowed to be plugged into other adapters. The store does not have adapters for all possible combinations of plugs and receptacles, but there is essentially an unlimited supply of the ones they do have.
Input

The input will consist of one case. The first line contains a single positive integer n (1 <= n <= 100) indicating the number of receptacles in the room. The next n lines list the receptacle types found in the room. Each receptacle type consists of a string of at most 24 alphanumeric characters. The next line contains a single positive integer m (1 <= m <= 100) indicating the number of devices you would like to plug in. Each of the next m lines lists the name of a device followed by the type of plug it uses (which is identical to the type of receptacle it requires). A device name is a string of at most 24 alphanumeric
characters. No two devices will have exactly the same name. The plug type is separated from the device name by a space. The next line contains a single positive integer k (1 <= k <= 100) indicating the number of different varieties of adapters that are available. Each of the next k lines describes a variety of adapter, giving the type of receptacle provided by the adapter, followed by a space, followed by the type of plug.
Output

A line containing a single non-negative integer indicating the smallest number of devices that cannot be plugged in.
Sample Input

4
A
B
C
D
5
laptop B
phone C
pager B
clock B
comb X
3
B X
X A
X D
Sample Output

1

题意

给定n种插座,每种一个。
给定m个用电器,每个用电器有其适配的插座类型。
给定q种转化器,每种不限量(因为题目是说去商店买转化器,所以认为有无限个)。
求最少有多少个用电器不能充电(同时充电)。

分析

阅读理解题。
就像用网络流解二分图匹配一样。对每一个”匹配“连一条容量为1的有向弧。
这里的匹配有:
源点到各个用电器;
用电器到插座;
插座通过转化器到插座(注意:因为转化器无限个,故合并有向弧后容量为无穷大)
插座到源点。
最后输出用 电器总数m-最大流 即可。

AC代码

//16ms 0.3MB
#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
#include <map>
#include <vector>
#include <string>
#define INF 0x3f3f3f3f
using namespace std;

int S,T;//源点和汇点
const int maxe=1e4+1000;
const int maxv=1100;
struct edge
{
    int to,w,next;
}e[maxe<<1];
int head[maxv<<1],depth[maxv],cnt;
void init()
{
    memset(head,-1,sizeof(head));
    cnt=-1;
}
void add_edge(int u,int v,int w)
{
    e[++cnt].to=v;
    e[cnt].w=w;
    e[cnt].next=head[u];
    head[u]=cnt;
}
void _add(int u,int v,int w)
{
    add_edge(u,v,w);
    add_edge(v,u,0);
}

bool bfs()
{
    queue<int> q;
    while(!q.empty()) q.pop();
    memset(depth,0,sizeof(depth));
    depth[S]=1;
    q.push(S);

    while(!q.empty())
    {
        int u=q.front();q.pop();
        for(int i=head[u];i!=-1;i=e[i].next)
        {
            if(!depth[e[i].to] && e[i].w>0)
            {
                depth[e[i].to]=depth[u]+1;
                q.push(e[i].to);
            }
        }
    }
    if(!depth[T]) return false;
    return true;
}
int dfs(int u,int flow)
{
    if(u==T) return flow;
    int ret=0;
    for(int i=head[u];i!=-1 && flow;i=e[i].next)
    {
        if(depth[u]+1==depth[e[i].to] && e[i].w!=0)
        {
            int tmp=dfs(e[i].to,min(e[i].w,flow));
            if(tmp>0)
            {
                flow-=tmp;
                ret+=tmp;
                e[i].w-=tmp;
                e[i^1].w+=tmp;
            }
        }
    }
    return ret;
}
int Dinic()
{
    int ans=0;
    while(bfs())
    {
        ans+=dfs(0,INF);
    }
    return ans;
}

map<string,int> mp;
int num=0;
int main()
{
    ios::sync_with_stdio(false);
    init();
    S=0,T=600;
    int n;
    cin>>n;
    while(n--)
    {
        string s;
        cin>>s;
        if(!mp[s])
            mp[s]=++num;//插座编号
        _add(mp[s],T,1);
    }
    int m;
    cin>>m;
    int tmp=m;
    while(tmp--)
    {
        string s,t;
        cin>>s>>t;
        mp[s]=++num;//用电器编号
        if(!mp[t]) mp[t]=++num;//没提供的插座也要编号
        _add(S,mp[s],1);//源点流到用电器
        _add(mp[s],mp[t],1);//用电器流到插座
    }
    int q;
    cin>>q;
    while(q--)
    {
        string s,t;
        cin>>s>>t;
        if(!mp[s]) mp[s]=++num;
        if(!mp[t]) mp[t]=++num;
        _add(mp[s],mp[t],INF);
    }
    cout<<m-Dinic()<<endl;
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_37685156/article/details/80603991