poj 3006

很简单的一道素数题,注意的是,判断素数时要多考虑上1


Dirichlet's Theorem on Arithmetic Progressions
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 19100   Accepted: 9586

Description

If a and d are relatively prime positive integers, the arithmetic sequence beginning with a and increasing by d, i.e., aa + da + 2da + 3da + 4d, ..., contains infinitely many prime numbers. This fact is known as Dirichlet's Theorem on Arithmetic Progressions, which had been conjectured by Johann Carl Friedrich Gauss (1777 - 1855) and was proved by Johann Peter Gustav Lejeune Dirichlet (1805 - 1859) in 1837.

For example, the arithmetic sequence beginning with 2 and increasing by 3, i.e.,

2, 5, 8, 11, 14, 17, 20, 23, 26, 29, 32, 35, 38, 41, 44, 47, 50, 53, 56, 59, 62, 65, 68, 71, 74, 77, 80, 83, 86, 89, 92, 95, 98, ... ,

contains infinitely many prime numbers

2, 5, 11, 17, 23, 29, 41, 47, 53, 59, 71, 83, 89, ... .

Your mission, should you decide to accept it, is to write a program to find the nth prime number in this arithmetic sequence for given positive integers ad, and n.

Input

The input is a sequence of datasets. A dataset is a line containing three positive integers ad, and n separated by a space. a and d are relatively prime. You may assume a <= 9307, d <= 346, and n <= 210.

The end of the input is indicated by a line containing three zeros separated by a space. It is not a dataset.

Output

The output should be composed of as many lines as the number of the input datasets. Each line should contain a single integer and should never contain extra characters.

The output integer corresponding to a dataset adn should be the nth prime number among those contained in the arithmetic sequence beginning with a and increasing by d.

FYI, it is known that the result is always less than 106 (one million) under this input condition.

Sample Input

367 186 151
179 10 203
271 37 39
103 230 1
27 104 185
253 50 85
1 1 1
9075 337 210
307 24 79
331 221 177
259 170 40
269 58 102
0 0 0

Sample Output

92809
6709
12037
103
93523
14503
2
899429
5107
412717
22699
25673

#include<iostream>
#include<string>
#include<string.h>
using namespace std;
#include<algorithm> 
#include<math.h>


bool prime(int a)
{
	if(a==1)
	return false;
	for(int i=2;i<=sqrt(a+0.0);i++)
	{
		if(a%i==0)
		return false;		
	}	
	return true;
	
 } 
int main()
{
	int a,d,n;
	while(cin>>a>>d>>n,a+d+n)
	{
		int x=a;
		long long int count=0;
		while(count!=n)
		{
			if(prime(x))
			count++;
			x+=d;
		}
		if(a==1&&d==1&&n==1)
		cout<<2<<endl;
		else
		cout<<x-d<<endl;
	}
	 
	return 0;
}



发布了19 篇原创文章 · 获赞 15 · 访问量 1777

猜你喜欢

转载自blog.csdn.net/ned158/article/details/77688520