贪心 时间安排问题

Training 1 - A 题

“今年暑假不AC?”

“是的。”

“那你干什么呢?”

“看世界杯呀,笨蛋!”

“@#$%^&*%…”

确实如此,世界杯来了,球迷的节日也来了,估计很多ACMer也会抛开电脑,奔向电视了。

作为球迷,一定想看尽量多的完整的比赛,当然,作为新时代的好青年,你一定还会看一些其它的节目,比如新闻联播(永远不要忘记关心国家大事)、非常6+7、超级女生,以及王小丫的《开心辞典》等等,假设你已经知道了所有你喜欢看的电视节目的转播时间表,你会合理安排吗?(目标是能看尽量多的完整节目)

Input

输入数据包含多个测试实例,每个测试实例的第一行只有一个整数n(n<=100),表示你喜欢看的节目的总数,然后是n行数据,每行包括两个数据Ti_s,Ti_e (1<=i<=n),分别表示第i个节目的开始和结束时间,为了简化问题,每个时间都用一个正整数表示。n=0表示输入结束,不做处理。

Output

对于每个测试实例,输出能完整看到的电视节目的个数,每个测试实例的输出占一行。

对于每个测试实例,输出能完整看到的电视节目的个数,每个测试实例的输出占一行。

Sample Input

12
1 3
3 4
0 7
3 8
15 19
15 20
10 15
8 18
6 12
5 10
4 14
2 9
0

扫描二维码关注公众号,回复: 9796340 查看本文章

Sample Output

5

#pragma warning (disable:4996)
#include <iostream>
#include <algorithm>
#include <iomanip>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <queue>
#include <bitset>
#include <stack>
#include <queue>
#define inf 0X7f7f7f7f
using namespace std;
typedef long long ll;
typedef unsigned long long ull;
const int maxn = 1e5 + 5;

struct N
{
	int begin;
	int end;
};

bool cmp(N x, N y)
{
	if (x.end == y.end)
		return true;
	return x.end < y.end;
}
N a[105];

int main()
{
	int n;
	scanf("%d", &n);
	while (n != 0)
	{
		int ans = 0;
		for (int i = 1; i <= n; i++)
			scanf("%d%d", &a[i].begin, &a[i].end);
		sort(a + 1, a + n + 1, cmp);
		int end = 0;
		for (int i = 1; i <= n; i++)
		{
			if (a[i].begin >= end)
			{
				ans++;
				end = a[i].end;
			}
		}
		printf("%d\n", ans);
		scanf("%d", &n);
	}
	return 0;
}

思路:
将所有时间段输入后,按照结束时间,从小到大排序。遍历,找到当前情况下结束时间最小且开始时间满足条件的时间段,更新答案。

发布了28 篇原创文章 · 获赞 0 · 访问量 343

猜你喜欢

转载自blog.csdn.net/xukeke12138/article/details/104522939