Number Sequence(矩阵快速幂)

Number Sequence

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 193186 Accepted Submission(s): 48330

Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

Output
For each test case, print the value of f(n) on a single line.

Sample Input
1 1 3
1 2 10
0 0 0

Sample Output
2
5

Author
CHEN, Shunbao

Source
ZJCPC2004

扫描二维码关注公众号,回复: 960891 查看本文章

Recommend
JGShining | We have carefully selected several similar problems for you: 1008 1004 1021 1019 1001

要得到的矩阵 乘的矩阵 开始的矩阵
F[n] = [A B] F[n-1]
F[n-1] [1 0] F[n-2]
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
using namespace std;
typedef long long ll;
int n;
ll MOD = 7;
struct mat
{
    ll m[4][4];
} init, q;
ll mod(ll x)
{
    return (x+MOD)%MOD;
}
void init_mat()
{
    for(int i=0; i<n; i++)
    {
        for(int j=0; j<n; j++)
        {
            init.m[i][j] = 0;
            q.m[i][j] = 0;
        }
    }
}

mat operator *(mat a, mat b)
{
    mat ret;
    ll x;
    for(int i=0; i<n; i++)
    {
        for(int j=0; j<n; j++)
        {
            x = 0;
            for(int k=0; k<n; k++)
            {
                x += mod((ll)(a.m[i][k]*b.m[k][j]));
                x %=MOD;
            }
            ret.m[i][j] = x;
        }
    }
    return ret;
}

mat mat_pow(mat a, ll x)
{
    mat ret;
    for(int i=0; i<n; i++)
    {
        for(int j=0; j<n; j++)
        {
            if(j==i)
                ret.m[i][j] = 1;
            else
                ret.m[i][j] = 0;
        }
    }
    while(x)
    {
        if(x&1)
            ret = ret * a;
        a = a * a;
        x>>=1;
    }
    return ret;
}
int main()
{
    ll a, b, c;
    n = 2;
    while(~scanf("%lld %lld %lld", &a, &b, &c))
    {
        if(a==0&&b==0&&c==0)
            break;
        if(c==1)
            cout<<1<<endl;
        else if(c==2)
            cout<<1<<endl;
        else
        {
            init_mat();
            init.m[0][0] = a;
            init.m[0][1] = b;
            init.m[1][0] = 1;
            init.m[1][1] = 0;
            q.m[0][0] = 1;
            q.m[1][0] = 1;
            mat a = mat_pow(init, c-2);
            a = a * q;
            cout<<mod((ll)a.m[0][0])<<endl;
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/feather2016/article/details/79941965