hdu 1017 A Mathematical Curiosity

Problem Description

Given two integers n and m, count the number of pairs of integers (a,b) such that 0 < a < b < n and (a^2+b^2 +m)/(ab) is an integer.
This problem contains multiple test cases!
The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.
The output format consists of N output blocks. There is a blank line between output blocks.

Input

You will be given a number of cases in the input. Each case is specified by a line containing the integers n and m. The end of input is indicated by a case in which n = m = 0. You may assume that 0 < n <= 100.

Output

For each case, print the case number as well as the number of pairs (a,b) satisfying the given property. Print the output for each case on one line in the format as shown below.

Sample Input

1
10 1
20 3
30 4
0 0

Sample Output

Case 1: 2
Case 2: 4
Case 3: 5
 
题意不难,输出格式emmmmmm,英语不好的我看的头皮发麻,试了好多次才实验对,意思是N个模块,每个模块都是0 0 结尾的
#include <algorithm>
#include <iostream>
#include <cstring>
#include <cstdio>
#include <vector>
#include <cmath>
#include <queue>
#include <deque>
#include <cmath>
#include <map>

using namespace std;
typedef long long ll;

const double inf=1e20;
const int maxn=1e5+10;
const int mod=1e9+7;

int main(){
    ll n,m;

    int x;
    scanf("%d",&x);
    while(x--){
        getchar();
        ll t=1;
        while(scanf("%lld%lld",&n,&m)){
            if(n==0&&m==0)break;
            ll num=0;
            for(ll i=1;i<n;i++){
                for(ll j=i+1;j<n;j++){
                    if( ((i*i)+(j*j)+m)%(i*j)==0)num++;
                }
            }

            printf("Case %lld: %lld\n",t++,num);
        }
        if(x)printf("\n");
    }
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/wz-archer/p/12405412.html