HDU 1017(A Mathematical Curiosity)

版权声明:本人原创,转载请注明出处! https://blog.csdn.net/qq_29117927/article/details/86610285
                                           A Mathematical Curiosity
           Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
                       Total Submission(s): 50812    Accepted Submission(s): 16465

Problem Description
Given two integers n and m, count the number of pairs of integers (a,b) such that 0 < a < b < n and (a2+b2 +m)/(ab) is an integer.

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.

Input
You will be given a number of cases in the input. Each case is specified by a line containing the integers n and m. The end of input is indicated by a case in which n = m = 0. You may assume that 0 < n <= 100.

Output
For each case, print the case number as well as the number of pairs (a,b) satisfying the given property. Print the output for each case on one line in the format as shown below.

Sample Input
1

10 1
20 3
30 4
0 0

Sample Output
Case 1: 2
Case 2: 4
Case 3: 5

#include<iostream>
using namespace std;
int main()
{
    int a,b,num=0,count=0,i,j,n;
    cin>>n;
    while(n--)
    {
        while(cin>>a>>b)
        {
            if(a==0&&b==0)
                break;
            for(i=1;i<a;i++)
            {
                for(j=i+1;j<a;j++)
                {
                    if((i*i+j*j+b)%(i*j)==0)
                        num++;
                }
            }
            count++;
            cout<<"Case "<<count<<": "<<num<<endl;
            num=0;
        }
        if(n)
            cout<<endl;
        count=0;
    }
}

猜你喜欢

转载自blog.csdn.net/qq_29117927/article/details/86610285