HDU ACM1017——A Mathematical Curiosity

A Mathematical Curiosity

Problem Description

Given two integers n and m, count the number of pairs of integers (a,b) such that 0 < a < b < n and (a^2+b^2 +m)/(ab) is an integer.

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.

Input

You will be given a number of cases in the input. Each case is specified by a line containing the integers n and m. The end of input is indicated by a case in which n = m = 0. You may assume that 0 < n <= 100.

Output

For each case, print the case number as well as the number of pairs (a,b) satisfying the given property. Print the output for each case on one line in the format as shown below.

Sample Input

1

10 1
20 3
30 4
0 0

Sample Output

Case 1: 2
Case 2: 4
Case 3: 5

题目大意:就是a,b不断循环找整数的问题。
题目意思很好理解,但最关键的是这道题的输入输出格式太恶心了,试了好几次才过。

#include<stdio.h>
int main()
{
    int N,n,m,cont,a,b;
    while(scanf("%d",&N)!=EOF){
        while(N--){
            int c=1;    //从Case1开始不断增加,注意是在N循环内,每个输入块要更新 
            while(1){   //每个输入块不断循环直到n=0 
                scanf("%d %d",&n,&m);
                cont=0;
                if(n==0)break;
                for(a=1;a<n-1;a++){  //求整数个数 
                    for(b=a+1;b<n;b++) 
                        if((a*a+b*b+m)%(a*b)==0)  
                            cont++;   
                }
                printf("Case %d: %d\n",c++,cont);
            }
            if(N) printf("\n");     //注意,这里还需换行,因为输入0 0结束没有换行。。。 
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/BarisGuo/article/details/82079349