暑假训练 Largest Rectangle in a Histogram HDU - 1506 dp

题目描述:
A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles:
Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.

Input
The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1 <= n <= 100000. Then follow n integers h1, …, hn, where 0 <= hi <= 1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.

Output
For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.

Sample Input
7 2 1 4 5 1 3 3
4 1000 1000 1000 1000
0

Sample Output
8
4000
code:

#include<cstdio>
#include<string.h>
#include<algorithm>

using namespace std;
const int maxn = 1e5+5;
long long a[maxn];
long long l[maxn], r[maxn];         //分别记录左右边界

int main()
{
    int n;
    while(~scanf("%d", &n) && n)
    {
        for(int i = 1; i <= n; i++)
            scanf("%lld", &a[i]);
        l[1] = 1;
        r[n] = n;
        for(int i = 2; i <= n; i++)
        {
            int t = i;
            while(t > 1 && a[i] <= a[t-1])
                t = l[t-1];                                     //这个操作就很精妙了
            l[i] = t;
        }
        for(int i = n-1; i >= 1; i--)
        {
            int t = i;
            while(t < n && a[i] <= a[t+1])
                t= r[t+1];
            r[i] = t;
        }
        long long ans = 0;
        for(int i = 1; i <= n; i++)
        {
            ans = max(ans, (r[i] - l[i] + 1)*a[i]);
        }
        printf("%lld\n", ans);
    }
    return 0;
}

emmmm,又一次输给dp了,只要找出最大矩形就可以了,不过直接找要n²时间,然而dp就可很快找出一定高度的边界了。。。

猜你喜欢

转载自blog.csdn.net/wbl1970353515/article/details/82956215