PAT(A)1121 Damn Single (25point(s))

在这里插入图片描述

Sample Input

3
11111 22222
33333 44444
55555 66666
7
55555 44444 10000 88888 22222 11111 23333

Sample Output

5
10000 23333 44444 55555 88888

思路:
map记录输出。
代码

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <string>
#include <cstring>
#include <vector>
#include <map>
#include <cmath>

using namespace std;

#define endl '\n'

typedef long long ll;

map<string, string>mp;
map<string, int>mp1;

vector<string>v1;
vector<string>v2;

int main()
{
    int n;
    cin >> n;

    for (int i = 0; i < n; ++i)
    {
        string x, y;
        cin >> x >> y;
        mp[x] = y;
        mp[y] = x;
    }

    int m;
    cin >> m;

    for (int i = 0; i < m; ++i)
    {
        string x;
        cin >> x;
        mp1[x] = 1;
        v1.push_back(x);
    }

    for (int i = 0; i < v1.size(); ++i)
    {
        if (mp1[mp[v1[i]]] != 1)
            v2.push_back(v1[i]);
    }

    sort(v2.begin(), v2.end());

    cout << v2.size() << endl;

    for (int i = 0; i < v2.size(); ++i)
    {
        cout << v2[i];
        if (i != v2.size() - 1)
            cout << " ";
    }

    // cout << endl;

    return 0;
}

发布了161 篇原创文章 · 获赞 7 · 访问量 7079

猜你喜欢

转载自blog.csdn.net/weixin_43778744/article/details/104142616