1025 PAT Ranking (25point(s))

首先,先贴柳神的博客

https://www.liuchuo.net/ 这是地址

想要刷好PTA,强烈推荐柳神的博客,和算法笔记

题目原文

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (≤100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (≤300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank   

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:

2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85 

Sample Output:

9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4

题目大意

就是PTA在多个地方举办了考试,现在要你算出考生在自己考区的成绩和在总考取的成绩

错误代码

我的错误代码如下

#include<iostream>
#include<map>
#include<vector>

#include <algorithm>
using namespace std;
struct node {
    string id;
    int grade;
    int area;       //local_number;
    int rank[2];    //rank[0]是本地的成绩,rank[1]是总的成绩
};
bool cmp(node a, node b) {
    return a.grade > b.grade;
}
bool cmp2(node a, node b) {
    if (a.grade != b.grade)
        return a.grade > b.grade;
    else if (a.rank[0] != b.rank[0])
        return a.grade > b.grade;
    else 
        return a.id > b.id;
}
int main(void) {
    int N,M;
    int sum = 0;
    vector<node> data;
    scanf("%d", &N);
    for (int i = 0; i < N; i++) {
        scanf("%d", &M);
        sum += M;
        vector<node> area(M);
        for (int j = 0; j < M; j++) {
            cin >> area[j].id;
            scanf("%d", &area[j].grade);
            area[j].area = i + 1;
        }
        sort(area.begin(), area.end(),cmp);
        for (int j = 0; j < M; j++) {
            area[j].rank[0] = j+1;
        }
        for (int j = 1; j < M; j++) {
            if (area[j].grade == area[j - 1].grade) {
                area[j].rank[0] = area[j - 1].rank[0];
            }
        }
        for (int j = 0; j < M; j++) {
            data.push_back(area[j]);
        }
        
    }
    sort(data.begin(), data.end(), cmp);
    for (int j = 0; j < sum; j++) {
        data[j].rank[1] = j;
    }
    for (int j = 1; j < sum;j++) {
        if (data[j].grade == data[j - 1].grade) {
            data[j].rank[1] = data[j - 1].rank[1];
        }
    }
    sort(data.begin(), data.end(), cmp2);
    printf("%d\n", sum);

    printf("\n%d\n", data.size());

    for (auto w : data) {
        printf("%s %d %d %d\n", w.id, w.rank[0], w.area, w.rank[1]);
    }
    return 0;
}

柳神的正确代码

#include <cstdio>
#include <algorithm>
#include <vector>
using namespace std;
struct student {
    long long int no;       //证件号
    int score, finrank, loca, locarank;
};
bool cmp1(student a, student b) {
    return a.score != b.score ? a.score > b.score : a.no < b.no;
}
int main() {
    int n, m;
    scanf("%d", &n);
    vector<student> fin;
    for (int i = 1; i <= n; i++) {
        scanf("%d", &m);
        vector<student> v(m);
        for (int j = 0; j < m; j++) {
            scanf("%lld %d", &v[j].no,&v[j].score);
            v[j].loca = i;
        }
        sort(v.begin(), v.end(), cmp1);
        v[0].locarank = 1;
        fin.push_back(v[0]);
        for (int j = 1; j < m; j++) {
            v[j].locarank = (v[j].score == v[j - 1].score) ? (v[j - 1].locarank) : (j + 1);
            fin.push_back(v[j]);
        }
    }
    sort(fin.begin(), fin.end(), cmp1);
    fin[0].finrank = 1;
    for (int j = 1; j < fin.size(); j++)
        fin[j].finrank = (fin[j].score == fin[j - 1].score) ? (fin[j - 1].finrank) : (j + 1);
    printf("%d\n", fin.size());
    for (int i = 0; i < fin.size(); i++)
        printf("%013lld %d %d %d\n", fin[i].no, fin[i].finrank, fin[i].loca, fin[i].locarank);
    return 0;
}

我改过的代码

#include<iostream>
#include<map>
#include<vector>

#include <algorithm>
using namespace std;
struct node {
    string id;
    int grade;
    int area;       //local_number;
    int rank[2];    //rank[0]是本地的成绩,rank[1]是总的成绩
};
bool cmp1(node a, node b) {
    return a.grade != b.grade ? a.grade > b.grade : a.id < b.id;
}
int main(void) {
    int N, M;
    vector<node> data;
    scanf("%d", &N);
    for (int i = 0; i < N; i++) {
        scanf("%d", &M);
        vector<node> area(M);
        for (int j = 0; j < M; j++) {
            cin >> area[j].id;
            scanf("%d", &area[j].grade);
            area[j].area = i + 1;
        }
        sort(area.begin(), area.end(), cmp1);
        area[0].rank[0] = 1;
        data.push_back(area[0]);
        for (int j = 1; j < M; j++) {
            if (area[j].grade == area[j - 1].grade) {
                area[j].rank[0] = area[j - 1].rank[0];
            }
            else
                area[j].rank[0] = j + 1;
            data.push_back(area[j]);
        }
    }
    sort(data.begin(), data.end(), cmp1);
    for (int j = 0; j < data.size(); j++) {
        data[j].rank[1] = j+1;
    }
    for (int j = 1; j < data.size(); j++) {
        if (data[j].grade == data[j - 1].grade) {
            data[j].rank[1] = data[j - 1].rank[1];
        }
    }
    sort(data.begin(), data.end(), cmp1);
    printf("%d\n", data.size());
    for (int i = 0; i < data.size();i++) {
        cout <<data[i].id;
        printf(" %d %d %d\n",data[i].rank[1], data[i].area, data[i].rank[0]);
    }
    return 0;
}

总结和反思

这题我看懂了,做了,错了,但是好的事情是我和柳神的思路差不多,所以后来我改了改也就对了,暴露出来的问题有

① C++的STL里面的函数还是不太会用,有些很好用的比如sort函数拉,一定有学会用

② 在许多的细节上还是有注意区分,比如C++里面的String类型,我的认识就有问题

③ 阅读英文的能力真的是有够差的

猜你喜欢

转载自www.cnblogs.com/a-small-Trainee/p/12450471.html