PAT (Advanced Level) Practice 1121 Damn Single(25 分)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/Puppettt/article/details/82180289

1121 Damn Single(25 分)

"Damn Single (单身狗)" is the Chinese nickname for someone who is being single. You are supposed to find those who are alone in a big party, so they can be taken care of.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 50,000), the total number of couples. Then N lines of the couples follow, each gives a couple of ID's which are 5-digit numbers (i.e. from 00000 to 99999). After the list of couples, there is a positive integer M (≤ 10,000) followed by M ID's of the party guests. The numbers are separated by spaces. It is guaranteed that nobody is having bigamous marriage (重婚) or dangling with more than one companion.

Output Specification:

First print in a line the total number of lonely guests. Then in the next line, print their ID's in increasing order. The numbers must be separated by exactly 1 space, and there must be no extra space at the end of the line.

Sample Input:

3
11111 22222
33333 44444
55555 66666
7
55555 44444 10000 88888 22222 11111 23333

Sample Output:

5
10000 23333 44444 55555 88888

题意:给你n对夫妻的编号,问m个人中没有对象在场的编号,升序输出;

代码:

#include <bits/stdc++.h>
using namespace std;
const int maxn=1e5;
int lin[maxn];
int main()
{
    for(int i=0;i<maxn;i++)lin[i]=-1;
    int n;cin>>n;
    int a,b;
    for(int i=0;i<n;i++)
    {
        cin>>a>>b;
        lin[a]=b;
        lin[b]=a;
    }
    int m;
    cin>>m;
    int vis[maxn]={0},cos[maxn];
    memset(vis,0,sizeof(vis));
    for(int i=0;i<m;i++)
    {
        scanf("%d",&cos[i]);
        vis[cos[i]]=1;
    }
    set<int >s;
    s.clear();
    for(int i=0;i<m;i++)
    {
        int p=lin[cos[i]];
        if(p==-1||!vis[p]){s.insert(cos[i]);}
    }

    printf("%d\n",s.size());
    set<int>::iterator it;
    for(it=s.begin();it!=s.end();it++)
    {
        if(it!=s.begin())printf(" ");
        printf("%05d",*it);
    }
    if(s.size()>0)printf("\n");
}

猜你喜欢

转载自blog.csdn.net/Puppettt/article/details/82180289