【PAT】A1121 Damn Single (25point(s))


Author: CHEN, Yue
Organization: 浙江大学
Time Limit: 200 ms
Memory Limit: 64 MB
Code Size Limit: 16 KB

A1121 Damn Single (25point(s))

“Damn Single (单身狗)” is the Chinese nickname for someone who is being single. You are supposed to find those who are alone in a big party, so they can be taken care of.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 50,000), the total number of couples. Then N lines of the couples follow, each gives a couple of ID’s which are 5-digit numbers (i.e. from 00000 to 99999). After the list of couples, there is a positive integer M (≤ 10,000) followed by M ID’s of the party guests. The numbers are separated by spaces. It is guaranteed that nobody is having bigamous marriage (重婚) or dangling with more than one companion.

Output Specification:

First print in a line the total number of lonely guests. Then in the next line, print their ID’s in increasing order. The numbers must be separated by exactly 1 space, and there must be no extra space at the end of the line.

Sample Input:

3
11111 22222
33333 44444
55555 66666
7
55555 44444 10000 88888 22222 11111 23333

Sample Output:

5
10000 23333 44444 55555 88888

Code

#include <bits/stdc++.h>
using namespace std;
vector<int> res,temp;
int isshow[100000],relation[100000];
int main(){
    int n,m,a,b;
    scanf("%d",&n);
    memset(relation,-1,100000);
    for(int i=0;i<n;i++){
        scanf("%d %d",&a,&b);
        relation[a]=b;
        relation[b]=a;
    }
    scanf("%d",&m);
    for(int i=0;i<m;i++){
        scanf("%d",&a);
        temp.push_back(a);
        if(relation[a]==-1) res.push_back(a);
        else    isshow[a]=1;
    }
    for(int i=0;i<temp.size();i++){
        if(relation[temp[i]]!=-1&&isshow[relation[temp[i]]]!=1)
            res.push_back(temp[i]);
    }
    sort(res.begin(),res.end());
    printf("%d\n",res.size());
    for(int i=0;i<res.size();i++){
        if(i==0)    printf("%05d",res[i]);
        else    printf(" %05d",res[i]);
    }
}

Analysis

-给出一对对夫妻。然后给出出席的人的编号,求其中单身的人数和所有单身的人的ID。

发布了159 篇原创文章 · 获赞 17 · 访问量 1万+

猜你喜欢

转载自blog.csdn.net/ztmajor/article/details/104036495