PAT 甲级 1121 Damn Single

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/a845717607/article/details/87900638

1121 Damn Single (25 point(s))

"Damn Single (单身狗)" is the Chinese nickname for someone who is being single. You are supposed to find those who are alone in a big party, so they can be taken care of.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 50,000), the total number of couples. Then N lines of the couples follow, each gives a couple of ID's which are 5-digit numbers (i.e. from 00000 to 99999). After the list of couples, there is a positive integer M (≤ 10,000) followed by M ID's of the party guests. The numbers are separated by spaces. It is guaranteed that nobody is having bigamous marriage (重婚) or dangling with more than one companion.

Output Specification:

First print in a line the total number of lonely guests. Then in the next line, print their ID's in increasing order. The numbers must be separated by exactly 1 space, and there must be no extra space at the end of the line.

Sample Input:

3
11111 22222
33333 44444
55555 66666
7
55555 44444 10000 88888 22222 11111 23333

Sample Output:

5
10000 23333 44444 55555 88888

经验总结:

emmmm 简单的划水题,考察的是hash的应用~

AC代码

#include <cstdio>
#include <algorithm>
#include <vector>
using namespace std;
const int maxn=100010;
int couple[maxn]={-1},n;
bool isattend[maxn]={false};
int main()
{
	int a,b;
	scanf("%d",&n);
	for(int i=0;i<n;++i)
	{
		scanf("%d%d",&a,&b);
		couple[a]=b;
		couple[b]=a;
	}
	vector<int> search,ans;
	scanf("%d",&n);
	search.resize(n);
	for(int i=0;i<n;++i)
	{
		scanf("%d",&search[i]);
		if(couple[search[i]]!=-1)
			isattend[couple[search[i]]]=true;
	}
	for(int i=0;i<n;++i)
	{
		if(isattend[search[i]]==false)
			ans.push_back(search[i]);
	}
	sort(ans.begin(),ans.end());
	printf("%d\n",ans.size());
	for(int i=0;i<ans.size();++i)
		printf("%05d%c",ans[i],i<ans.size()-1?' ':'\n');
	return 0;
}

猜你喜欢

转载自blog.csdn.net/a845717607/article/details/87900638