7-113 电话聊天狂人 (25分)

给定大量手机用户通话记录,找出其中通话次数最多的聊天狂人。

输入格式:

输入首先给出正整数N(≤),为通话记录条数。随后N行,每行给出一条通话记录。简单起见,这里只列出拨出方和接收方的11位数字构成的手机号码,其中以空格分隔。

输出格式:

在一行中给出聊天狂人的手机号码及其通话次数,其间以空格分隔。如果这样的人不唯一,则输出狂人中最小的号码及其通话次数,并且附加给出并列狂人的人数。

输入样例:

4
13005711862 13588625832
13505711862 13088625832
13588625832 18087925832
15005713862 13588625832
 

输出样例:

13588625832 3
#include<bits/stdc++.h>
using namespace std;
map<string,int> mp;
int main(){
    string a,b;
    int n,maxn=0,cnt=0;
    cin>>n;
    n*=2;
    while(n--){
        cin>>a;
        mp[a]++;
    }
    map<string,int>::iterator it;
    for(it=mp.begin();it!=mp.end();it++){
        if(it->second>=maxn){
            if(it->second>maxn){
                b=it->first;
                maxn=it->second;
            }
            if(it->second==maxn&&it->first<b)
            b=it->first;
            maxn=it->second;
        }
    }
    for(it=mp.begin();it!=mp.end();it++){
        if(it->second==maxn) cnt++;
    }
    cout<<b<<" "<<maxn;
    if(cnt>1) cout<<" "<<cnt;
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/fangkuaiya/p/12335463.html