7-8 电话聊天狂人 (25 分)

版权声明:本文为博主原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。
本文链接: https://blog.csdn.net/qq_41591279/article/details/88841748

给定大量手机用户通话记录,找出其中通话次数最多的聊天狂人。

输入格式:

输入首先给出正整数N(≤10​5​​),为通话记录条数。随后N行,每行给出一条通话记录。简单起见,这里只列出拨出方和接收方的11位数字构成的手机号码,其中以空格分隔。

输出格式:

在一行中给出聊天狂人的手机号码及其通话次数,其间以空格分隔。如果这样的人不唯一,则输出狂人中最小的号码及其通话次数,并且附加给出并列狂人的人数。

输入样例:

4
13005711862 13588625832
13505711862 13088625832
13588625832 18087925832
15005713862 13588625832

输出样例:

13588625832 3
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std ;
struct TEL{
	char tel[12] ;
};
bool cmp(struct TEL t1,struct TEL t2)
{
	return strcmp(t1.tel,t2.tel) < 0 ;
}
int main()
{
	int n ;
	scanf("%d",&n) ;
	getchar() ;
	struct TEL t[2*n+1] ;
	for(int i=0;i<2*n;i+=2)
	{
		scanf("%s %s",t[i].tel,t[i+1].tel) ;
		getchar() ;
	}
	sort(t,t+2*n,cmp) ;
//	for(int i=0;i<2*n;i++)
//	{
//		printf("%s\n",t[i].tel) ;
//		
//	}
	int count = 1 ;
	int chong = 1 ;
	int max = 1 ;
	char s[12] ;
	for(int i=0;i<2*n;i++)
	{
		if(strcmp(t[i].tel,t[i+1].tel)==0)
		{
			count++ ;
		}
		else
		{
			if(count>max)
			{
				max = count ;
				strcpy(s,t[i].tel) ;
				count = 1 ;
				chong = 1 ;
			}
			else if(count==max)
			{
				chong++ ;
				count = 1 ;
			}
			else
				count = 1 ;
		}
	}
	if(chong==1)
		printf("%s %d\n",s,max) ;
	else
		printf("%s %d %d\n",s,max,chong) ;
}

猜你喜欢

转载自blog.csdn.net/qq_41591279/article/details/88841748