电话聊天狂人(25 分)

电话聊天狂人(25 分)

给定大量手机用户通话记录,找出其中通话次数最多的聊天狂人。

输入格式:

输入首先给出正整数N105),为通话记录条数。随后N行,每行给出一条通话记录。简单起见,这里只列出拨出方和接收方的11位数字构成的手机号码,其中以空格分隔。

输出格式:

在一行中给出聊天狂人的手机号码及其通话次数,其间以空格分隔。如果这样的人不唯一,则输出狂人中最小的号码及其通话次数,并且附加给出并列狂人的人数。

输入样例:

4
13005711862 13588625832
13505711862 13088625832
13588625832 18087925832
15005713862 13588625832

输出样例:

13588625832 3

简单木桶排序一下就行了,因为手机号位数过长,所以我用的map函数,第三个样例时间过长

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<map>
#include<queue>
#include<string.h>
#include<string>
#include<vector>
#include<set>
#include<stack>
#define INF 0x3f3f3f3f
using namespace std;
map<long long,int> c;
int ma[10005];
int main()
{
                int n;
                cin>>n;
                int max=0;
                long long s;
                while(n--)
                {
                    long long a,b;
                    cin>>a>>b;
                    c[a]++;
                    if(c[a]>max)
                    {
                        max=c[a];
                        ma[max]++;
                        s=a;
                    }
                    if(c[a]==max)
                    {
                        ma[max]++;
                        if(a<s)
                        {
                            s=a;
                        }
                    }
                    c[b]++;
                    if(c[b]>max)
                    {
                        ma[max]++;
                        max=c[b];
                        s=b;
                    }
                    if(c[b]==max)
                    {
                        ma[max]++;
                        if(b<s)
                        {
                            s=b;
                        }
                    }

                }
                if(ma[max]!=1)cout<<s<<" "<<max<<" "<<ma[max]<<endl;
                else cout<<s<<" "<<max<<endl;
                return 0;

}

猜你喜欢

转载自blog.csdn.net/nihaopeng521/article/details/79537665