7-33 电话聊天狂人

给定大量手机用户通话记录,找出其中通话次数最多的聊天狂人。

输入格式:

输入首先给出正整数N(≤10​5​​),为通话记录条数。随后N行,每行给出一条通话记录。简单起见,这里只列出拨出方和接收方的11位数字构成的手机号码,其中以空格分隔。

输出格式:

在一行中给出聊天狂人的手机号码及其通话次数,其间以空格分隔。如果这样的人不唯一,则输出狂人中最小的号码及其通话次数,并且附加给出并列狂人的人数。

输入样例:

4
13005711862 13588625832
13505711862 13088625832
13588625832 18087925832
15005713862 13588625832

输出样例

  • map输入后自动排序,且区分大小写;
  • ans实时记录mp中最大次数,后遍历寻找,第一个找到的字符串保存;
  • 输出形式由记录次数的变量cnt决定;
#include<iostream>
#include<cstring>
#include<string>
#include<cstdio>
#include<map>
#include<cmath>
using namespace std;
map<string,int> mp;
int main(){
	int n;
	string s;
	scanf("%d",&n);
	int ans=0;
	for(int i=1;i<=n;i++){
		cin>>s;
		mp[s]++;
		ans=max(ans,mp[s]);
		cin>>s;
		mp[s]++;
		ans=max(ans,mp[s]);
	}
	int cnt=0;
	string first;
	map<string,int>::iterator it;
	for(it=mp.begin();it!=mp.end();it++){
		if(it->second==ans){
			if(cnt==0) first=it->first;
			cnt++; 
		}
	}
	if(cnt==1) cout<<first<<' '<<mp[first]<<endl;
	else cout<<first<<' '<<mp[first]<<' '<<cnt<<endl;
	return 0;
} 

猜你喜欢

转载自blog.csdn.net/qq_39825375/article/details/84889408