7-33 电话聊天狂人 (25 分)(map)

7-33 电话聊天狂人 (25 分)

给定大量手机用户通话记录,找出其中通话次数最多的聊天狂人。

输入格式:

输入首先给出正整数N(≤10​5​​),为通话记录条数。随后N行,每行给出一条通话记录。简单起见,这里只列出拨出方和接收方的11位数字构成的手机号码,其中以空格分隔。

输出格式:

在一行中给出聊天狂人的手机号码及其通话次数,其间以空格分隔。如果这样的人不唯一,则输出狂人中最小的号码及其通话次数,并且附加给出并列狂人的人数。

输入样例:

4
13005711862 13588625832
13505711862 13088625832
13588625832 18087925832
15005713862 13588625832

输出样例:

13588625832 3

代码:

#include<iostream>
#include<map>
using namespace std;
map<string,int> m;
map<string,int>::iterator it;
int main()
{
    int n,ans=0;
    cin>>n;
    string s1,s2;
    for(int i=0;i<n;i++)
    {
    	cin>>s1;
    	m[s1]++;
    	ans=max(ans,m[s1]);
    	cin>>s2;
    	m[s2]++;
        ans=max(ans,m[s2]);
	}
	int cnt=0;
	string num;
	for(it=m.begin();it!=m.end();it++)
	{
		if(it->second==ans)
		{
			if(cnt==0)  num=it->first;
			cnt++;
 		}
	}
	if(cnt==1) cout<<num<<" "<<m[num]<<endl;
	else  cout<<num<<" "<<m[num]<<" "<<cnt<<endl; 
	return 0;
 } 

猜你喜欢

转载自blog.csdn.net/daoshen1314/article/details/84960485